Did anything change with Server CE 5.6.0?

0

Hi guys.

I have a problem with installing Server 5.6.0 using the x64 Linux (ubuntu) Installer. This worked earlier this week but now on a clean install, Tomcat refuses connection.

I switched to 5.5.0a without changing anything else in the OS and that one works fine.

Anyone have any clues as to what may have changed?

Thanks.

 

*************************** UPDATE *****************************************

OK, after arm wrestling with this for about 12 hours, I think (not sure, think) my problem started when I installed an FTP Server. I have now verified that the problem happens ONLY when I install an FTP server (does not seem to matter if it is VSFTPD or PROFTP). My guess is that there is some sort of a conflict with Tomcat but am too tired to try to figure that out. I rebuilt my VM without an FTP server and everything is working. If you have installed an FTP server on the same server you are running Jasper, please post your config file(s).

*******************************************************************************

bob_8's picture
55
Joined: May 20 2014 - 10:59am
Last seen: 6 years 3 months ago

1 Answer:

0

What's the exact message? Are you sure you don't have another instance of Tomcat running? Check the tomcat log for any error messages. If Tomcat is running, try going to Manager to see if JasperReport Server instance is started.

hozawa's picture
69977
Joined: Apr 24 2010 - 4:31pm
Last seen: 1 year 8 months ago

Hi Hozawa. Thanks for the note.

The message is from Tomcat - connection refused. I tried to post the entire error log here but the Jaspersoft spam vendor, Mollom, flags it for some reason. No other instances of Tomcat were running at the time. I even rebooted the VM to make sure.

I am a bit confused. This does not make any sense to me, particularly since as recently as last Monday this worked just fine.

I will keep experimenting. Now I'm really curious.

Bob

bob_8 - 6 years 7 months ago

Are you trying to access it from within the VM or from outside? If outside, routing has to be setup. Try pinging the tomcat.
Most 404 error occurs when JasperReports Server is not running. Check Tomcat Manager Application Listing. Can't help too much without the log files.

hozawa - 6 years 7 months ago

I have not got to the "access part" yet. I am getting strange errors. I destroyed and rebuilt the vm, and downloaded the x64 installer again. When I tried to install it, I now get a new error:

Warning: Problem running post-install step. Installation may not complete
correctly
Error running /opt/jasperreports-server-cp-5.6.0/apache-ant/bin/ant import-ce
-DimportFile=install_resources/export/js-catalog :
BUILD FAILED
/opt/jasperreports-server-cp-5.6.0/buildomatic/bin/import-export.xml:260: The
following error occurred while executing this line:
/opt/jasperreports-server-cp-5.6.0/buildomatic/bin/import-export.xml:158: Java
returned: 1

Total time: 4 seconds

Very strange. These same steps worked as early as last Monday. Now all sorts of issues. No clue but will keep digging.

bob_8 - 6 years 7 months ago
show 1 more...

I think the problem started when I installed an FTP Server. Certainly does not happen if not FTP server is running. See my update above.

Thanks, again, for your help.

Bob

bob_8 - 6 years 7 months ago
Feedback
randomness