Getting "SyntaxError: missing ) after argument list" in visualize.js:59

0

I just include visualize.js in an empy html page and there is a following error in the console. Has anyone actually got visualize.js packaged with JasperReport Server to work?

"SyntaxError: missing ) after argument list" in  visualize.js:59

Attachments: 
hozawa's picture
44219
Joined: Apr 24 2010 - 4:31pm
Last seen: 1 month 6 days ago

Did you try to load visualize.js in html from local filesystem ?

nesterone - 5 years 4 weeks ago

I've tried loading from local filesystem, from Apache http server, and from putting them on the same application server as the JasperReports Server. The error, however, isn't about the server but about the syntax error in one of the Visualize.js script. The script file is loading but the web browser is complaining about the script having a syntax error.

I've used the JasperReports Server 5.6.0 upgrade war file.

I'll check if it's the file extracting error and also will try downloading the bundled installation package and see if I'll get the same syntax error problem.

Just wondering if anyone else is getting the same error.

The html file is like below so there's no other script nor tag that would cause syntax error.

<html>
<head>
<script type="text/javascript" src="http://localhost:8080/jasperserver-pro/client/visualize.js?logLevel=debug"></script>
</head>
<body>
Test
</body>
</html>
 

hozawa - 5 years 4 weeks ago

0 Answers:

No answers yet
Feedback