Clustered Tomcat JasperServer in Microsoft Azure Load Balanced Virtual Machines

0
Hi,
   I would like to know whether it is possible to work with Jasperserver deployed in a clustered Tomcat configured in the Microsoft Azure Load Balanced Virtual Machines
 
   Because jasperserver UI always gets crashed because of css/theme not loading in the above environment. I have explained the issue below and I am new to this environment, so please guide me to configure/solve this problem in the above environment.
 
   But the jasper document says,
 
        The load balancer must be configured so that browser users are always connected to the same server during a continuous session.
Transferring sessions should only happen if a node becomes disabled. Beyond that requirement, JasperReports Server can work with any HTTP load
balancer, both hardware or software-based.
 
The issue is :
 
           If only one instance, there is no problem and is working fine because it is maintaining only one JSESSIONID.
But if two tomcat in a clustered environment, Jasper UI gets collapsed because css/theme not loading, So I have investigated the request and response, more than one JSESSIONID involved and I don't know this issue is because of load balancer or session management of jasper, so please guide me to solve this problem.
 
Note: Sorry, for my bad english and I need the solution very urgently, So if you guide me, it will be really very helpful.
 
Error :
 
Failed to load resource: the server responded with a status of 404 (Not Found) https://domain-name/jasperserver-pro/_themes/C7141728/theme.css
Failed to load resource: the server responded with a status of 404 (Not Found) https://domain-name/jasperserver-pro/_themes/C7141728/pages.css
Failed to load resource: the server responded with a status of 404 (Not Found) https://domain-name/jasperserver-pro/_themes/C7141728/pageSpecific.css
Failed to load resource: the server responded with a status of 404 (Not Found) https://domain-name/jasperserver-pro/_themes/C7141728/dataDisplays.css
Failed to load resource: the server responded with a status of 404 (Not Found) https://domain-name/jasperserver-pro/_themes/C7141728/forPrint.css
Failed to load resource: the server responded with a status of 404 (Not Found) https://domain-name/jasperserver-pro/_themes/C7141728/images/lists_sprit...
Failed to load resource: the server responded with a status of 404 (Not Found) https://domain-name/jasperserver-pro/_themes/C7141728/images/button_acti...
Failed to load resource: the server responded with a status of 404 (Not Found) https://domain-name/jasperserver-pro/_themes/C7141728/images/wait_animat...
event.returnValue is deprecated. Please use the standard event.preventDefault() instead. require-jquery.js:5438
Denying load of chrome-extension://cjbjepchlgclmpinlbbeinajphohgfod/javascripts/jquery-2.0.2.min.map. Resources must be listed in the web_accessible_resources manifest key in order to be loaded by pages outside the extension. login.html:1
Denying load of chrome-extension://cjbjepchlgclmpinlbbeinajphohgfod/javascripts/jquery-2.0.2.min.map. Resources must be listed in the web_accessible_resources manifest key in order to be loaded by pages outside the extension. login.html:1
 
 
Environment :
1) Jasperserver 5.5 Commercial edition with session replication.
2) Two apache-tomcat-6.0.36 clustered instance.
3) Linux Machine - Ubuntu 13.10 Server.
 
Thanks,
Loganathan.
logu's picture
3
Joined: May 13 2014 - 4:08am
Last seen: 5 years 3 months ago

0 Answers:

No answers yet
Feedback