Build Jaspersoft Studio from source

0

I'm having problem with building Jaspersoft Studio from svn source. I've followed instructions on the following page.

http://community.jaspersoft.com/wiki/contributing-jaspersoft-studio-and-...

Unfortunately, when I load eclipse43x.p2f, eclipse tells me there is version conflict between "Eclilpse for RCP and RAP Developers" and "Eclipse Platform SDK". What is the actually versions necessary?

If I just try to "Generate Language Infrastructure" (because I've modified the sql.xtext file), I'm getting "Explicit encoding was set but is not supported by the available version of the AntlrToolRunner" error. Which version of Antlr do I actually need?

hozawa's picture
73727
Joined: Apr 24 2010 - 4:31pm
Last seen: 2 years 3 months ago

1 Answer:

0

The problem was with the instructions which used eclipse 4.2 instead of 4.3.1. All the sourceforge files for the current release of Jaspersoft Studio is currently using 4.3.1 so it was not working. Updated the site and a link to eclipse download site.

http://community.jaspersoft.com/wiki/contributing-jaspersoft-studio-and-...

hozawa's picture
73727
Joined: Apr 24 2010 - 4:31pm
Last seen: 2 years 3 months ago

Just noticed this. Thank you, Hozawa.

djohnson53 - 7 years 4 months ago
Feedback
randomness