jasperservice won't stop webpage is saying connection refused

0

Hi

Been running jasperserver 4.X, on a ubuntu box, for sometime no problem.  I created a report today and was creating the input filters when I ran the report I was getting a out of memory error.  I didn't understand why and decieded to reboot the machine.

When the machine came back up I couldn't logon to the webpage I get a Error Code 10061: Connection refused

When I logon onto the box and I try to stop the jasperservice I get the error

Catalina.stop: java.net.ConnectException: Connection refused: connect

 

I have attached a detailed screen capture:

screen dump

 

 

I have no idea whats wrong or where to begin. Would be very greatful if anyone can assist.

 

thanks

jasemilly's picture
Joined: Oct 6 2009 - 2:40am
Last seen: 1 year 9 months ago

3 Answers:

0

I would say that your tomcat process is dead. try to do a 'ps aux | grep [t]omcat' to see if there is still a tomcat process. If yes, you have to kill it with signal 15 and then with signal 9. Then, you can have a look at the catalina.out log file to have an idea of the reason and finally, you can try to restart your tomcat.

Regards

fcerbell's picture
264
Joined: Aug 14 2011 - 1:00pm
Last seen: 5 years 2 months ago
0
hozawa's picture
59134
Joined: Apr 24 2010 - 4:31pm
Last seen: 9 months 3 weeks ago
0

Now this is strange I have come in to work early this morning, and everything is working great.  I tried to stop the service and got a message saying it wasn't running.

 

DSo I started it, up it came.

 

DDoes this mean there is a clean up routine??

thanks for peoples comments, now back to the troublesome report.

 

 

jasemilly's picture
Joined: Oct 6 2009 - 2:40am
Last seen: 1 year 9 months ago
Feedback