Cannot delete report from jasper server: says cannot deserialize

0

Hi Experts,

I created a report in my local in jasper studio 5.5.0.final with a input parameter with datatype as string.

I saved it in jasper server (deployed on glassfish 2.0).

At server level I added input control of same name as the parameter I created in my local but by mistake with number data type.

Now when I run or edit my report in Jasper Server it gives me error org.apache.jasper.JasperException: java.lang.NullPointerException.

And when I try to delete this report it says cannot deserialize and does not let me delete the report.

If I try to delete the entire folder it says the folder contains item(s) which cannot be deleted.

From my jasper Studio in Repository Explorer I can’t expand this folder in which the corrupt report is there it says 

java.lang.Exception: The Server has returned an error with code 1 and with the message could not deserialize
at com.jaspersoft.ireport.jasperserver.ws.WSClient.list(WSClient.java:188)
at com.jaspersoft.ireport.jasperserver.ws.WSClient.list(WSClient.java:131)
at com.jaspersoft.studio.server.protocol.soap.SoapConnection.list(SoapConnection.java:69)
at com.jaspersoft.studio.server.protocol.ProxyConnection.list(ProxyConnection.java:57)
at com.jaspersoft.studio.server.WSClientHelper.listFolder(WSClientHelper.java:115)
at com.jaspersoft.studio.server.WSClientHelper.refreshResource(WSClientHelper.java:343)
at com.jaspersoft.studio.server.action.resource.RefreshResourcesAction$1.run(RefreshResourcesAction.java:65)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)
 

 so in Jasper Studio in that folder I can’t see other correct reports as well as the folder does not open.

Please help.

pujasakuja297's picture
Joined: Feb 6 2014 - 10:23am
Last seen: 2 years 4 months ago

Any help please...

pujasakuja297 - 5 years 8 months ago

Any help pls..

pujasakuja297 - 5 years 8 months ago

2 Answers:

1

I also encountered a very similar problem. The report was unable to be generated and I was unable to delete/edit/update it (constantly received the "cannot deserialize" error message). The suggested JIAccessEvent fix as suggested above did not work here. Instead, I enabled the general access log in MySQL and traced the problem to an input control in the report. Consequently, I deleted the offending InputControl and DataType from the JIResource table manually following the foreign keys from there to effectively cascade the delete. Once that was done I was able to delete the report from within JasperServer and re-upload it from JasperStudio.

Hopefully this will help if anyone else received a "cannot deserialize" error.

(Note: This was all completed with Jasper Server 5.6.0 on a MySQL database)

kevin_brown's picture
Joined: Jul 28 2014 - 8:05am
Last seen: 5 years 3 months ago
1

I am having the same problem which also extends to other report writers being unable to amend reports writen by others as JS overwrites the report on upload.

I have received the following workaround, not tried it though;

Assuming that the Jasper repository is in an Oracle database (as opposed to postgreSQL), a workaround is to delete all rows from the 'jiaccessevent' table prior to importing the reports. 

We ran into this issue a couple weeks back when we were troubleshooting the LRP report issue with BAE.  The way we worked around it then was to reload the Japser repository completely... but obviously that's not ideal.

Deleting from the 'jiaccessevent' table is less intrusive.  From what I've been able to figure out, this is just an auditing table that sits between the user table, and the 'jiresource' table. From what I can tell is it just keeps track of who viewed/touched what report, and when

 

phillip.howcroft's picture
Joined: Nov 28 2013 - 1:19am
Last seen: 5 months 2 weeks ago

I redeployed jasper server altogether and published all reports again, it was rework but got rid of the error.

pujasakuja297 - 5 years 3 months ago
Feedback
randomness