Why are null values in my crosstab blank spaces and not '0'

0

I'm trying to create a crosstab in my ad hoc editor. The values in the crosstab that are NULL show up as a blank space. Is there any way that I can change this to show '0' instead? 

I've attached a picture

Attachments: 
shauntae_mitchell's picture
Joined: Dec 18 2013 - 9:15am
Last seen: 5 years 8 months ago

3 Answers:

0

Hi there - 

I am not sure if you can set that from the Ad Hoc editor.  However, you could save the View as a report, and then open the file in iReport or Studio and make some changes, but that requires knowing how to use one of those two platforms.  You can open reports from the server using iReport or Studio (via the repository plug-in).

Regards, Hugo 

H Mendoza's picture
351
Joined: Feb 20 2013 - 11:39am
Last seen: 5 months 5 days ago
1

Hello,

If you log in as superuser and go to "Manage" > "Server Settings" > "Ad Hoc Settings", there is a setting called "Display Null as Zero".  This should display your nulls as zero.

-Kris

kcollins's picture
4177
Joined: Aug 30 2011 - 12:22pm
Last seen: 2 months 2 days ago

Is that feature in the newest release, 5.5? I don't see it in 5.0.

H Mendoza - 5 years 11 months ago

Yes, I believe it was introduced in version 5.2.

kcollins - 5 years 11 months ago
0

One caution here is that, this setting this option will change "Null" values as "0" for reports created using Adhoc views. For reports created using Jasper studio, the null values will appear as null. In order to handle nulls, we should put a condition as follows:

<field Name>== null ? 0: <fieldname>

HTH

Gowtham

 

gowthamsenmca's picture
Joined: Oct 15 2013 - 4:52am
Last seen: 3 years 2 months ago
Feedback
randomness