Jasperserver CP 5.5.0 Input parameters are disabled when scheduling

4

Hi,

First of all, thanks for this new version 5.5.0.

I have a problem when scheduling my reports, the parameters tab is disabled/grey, like in this screenshot:

The parameters I use are set to "Mandatory" and "Visible", and type is "Single Select Query". They work fine when running the reports manually, but when I schedule a report, I can't go into the "Parameters" tab.

I am wondering why. I must have missed something with this new version 5.5.0, maybe a configuration file? because all was working fine in version 5.2.

Thanks.

 

 

 

 

olivedev's picture
Joined: Sep 6 2011 - 7:28am
Last seen: 1 month 2 weeks ago

11 Answers:

0

Hi,

i think its the same problem like this:
http://community.jaspersoft.com/questions/820354/restv2reports-not-woking

look at your  jasperreports-server-cp-5.2.0/apache-tomcat/webapps/jasperserver/WEB-INF/logs/jasperserver.log.
Maybe you find something like this:
com.sun.jersey.api.NotFoundException: null for uri: http://x.x.x.x:8080/jasperserver/rest_v2/....

hingerl's picture
62
Joined: Nov 27 2006 - 2:45pm
Last seen: 2 years 7 months ago

Hi,

Thanks. Yes, I got this:

com.sun.jersey.api.NotFoundException: null for uri: http://172.18.200.106:9090/jasperserver/rest_v2/reports/Reports/UsageRep...

It seems that rest_v2 does not work at all.

http://172.18.200.106:9090/jasperserver/rest

gives: "Service not valid", which is fine.

However:

http://172.18.200.106:9090/jasperserver/rest_v2

gives: "Specified page not found"

What am I suppose to do to enable the rest_v2 service? I read the "jasperreports-server-web-services-guide.pdf" guide but can't find anything.

Thanks.

olivedev - 5 years 5 months ago
0

Sorry, if you could please delete this answer, I wanted to add a comment only.

olivedev's picture
Joined: Sep 6 2011 - 7:28am
Last seen: 1 month 2 weeks ago
0

A similar problem after upgrading from 5.2 to 5.5
When you upgrade there were no errors.

I ask your help to solve this problem ...

kharkov_max's picture
Joined: Nov 23 2010 - 3:01am
Last seen: 5 years 2 months ago
0

 

We have the same problem in version 5.5
Sheduling only works if there are no parameters.
luc.lidou's picture
Joined: Nov 14 2012 - 9:32am
Last seen: 3 years 1 month ago
0
nicolaslledo's picture
Joined: Jun 8 2010 - 8:12am
Last seen: 4 years 6 months ago
0

Having the same problem here with the parameter tab being disabled, has anyone found a solution/workaround yet? 

paauw's picture
3
Joined: Dec 20 2013 - 3:13am
Last seen: 5 years 3 months ago
0

Having the same issue here.

 

AndreC's picture
93
Joined: Dec 18 2009 - 12:05pm
Last seen: 3 weeks 5 hours ago
-1

Also the same problem!!!sad

harryssuperman's picture
Joined: Feb 12 2014 - 6:15am
Last seen: 5 years 1 month ago
0

same issue. any workaround found?

marzac_valentin's picture
Joined: Dec 12 2013 - 12:23am
Last seen: 4 years 12 months ago
0

still no solution for this issue?

erik.dittert's picture
Joined: Sep 20 2013 - 7:12am
Last seen: 2 months 2 weeks ago
0
q16marvin's picture
Joined: Nov 6 2012 - 9:39am
Last seen: 3 years 4 months ago
Feedback
randomness