exception getting dataset from cache

0

Hi

I am using jasperserver with Mongodb as data source. I have added the data source, test connection is successful. but after creating a topic when i try to create an ad hoc view for the report it gives me

The server has encountered an error. Please excuse the inconvenience.

Error Message

java.lang.RuntimeException: exception getting dataset from cache

Error Trace

"collectionName":"weekly_jasper_reports"} at
com.jaspersoft.commons.semantic.dsimpl.JRQueryDataSet$JRDataSetIterator.next(JRQueryDataSet.java:317) at
com.jaspersoft.commons.datarator.CachedData.fetchData(CachedData.java:135)
... 143 more
 
Caused by: net.sf.jasperreports.engine.JRException: No MongoDB connection at
com.jaspersoft.mongodb.query.MongoDbQueryExecuter.createDatasource(MongoDbQueryExecuter.java:114) at
com.jaspersoft.commons.semantic.dsimpl.JRQueryDataSet.getJRDataSource(JRQueryDataSet.java:190) at
com.jaspersoft.commons.semantic.dsimpl.JRQueryDataSet.access$100(JRQueryDataSet.java:51) at
com.jaspersoft.commons.semantic.dsimpl.JRQueryDataSet$JRDataSetIterator.next(JRQueryDataSet.java:308)
... 144 more

I have also tried with giving datasource in the specific topic but didn't solve my issu.

Need Help thanks

danish.anwar's picture
Joined: Oct 29 2013 - 5:46pm
Last seen: 5 years 11 months ago

I get the same error

Rodrigo Gregorio de las Heras - 2 years 3 months ago

1 Answer:

0
sanderse's picture
Joined: Jul 31 2017 - 3:51pm
Last seen: 2 weeks 2 days ago
Feedback
randomness