Error connecting to Jaspersoft Server from iReports on Mac

0

Hi,

I have bought a MacBook Pro (10.8.5) and installed iReports Professional 5.2.0 (Commercial edition). I can make the database connections and run my local report. Now I want to connect to Jaspersoft Server on AWS (AWS license). I can add a server, its properties, through the dialog, but when I try to open that server it gives me an error saying "java.net.ConnectException: Connection timed out".

On my other laptop (Windows) I have no problem connecting to the Jaspersoft Server. I want to get rid of this old machine. Does anyone have a solution for this problem?

Kind regards,

Patrick

patrick.dewitt's picture
Joined: Jun 19 2013 - 6:17am
Last seen: 2 years 8 months ago

1 Answer:

1

Can you connect using the IP Address?  It sounds like your machine is not able to resolve a domain name via DNS or something.

mgeise's picture
26697
Joined: Mar 5 2007 - 6:18am
Last seen: 8 months 3 days ago

I can reach the public DNS from my old laptop (Windows) through iReports. I can't ping either the public DNS name or IP-address from both laptops, but that's probably how AWS works. I tried to use the IP-address in the server properties without success. If I put the IP-address in a browser (Google, Safari) on the Mac, I can reach the machine.

patrick.dewitt - 6 years 10 months ago

I have found the problem for my Mac. I just entered the wrong port in the connection. I tried it from an instance on AWS and I also got the error. Within AWS it only seems to work when you enter the IP-address instead of the public DNS name.

patrick.dewitt - 6 years 10 months ago
Feedback
randomness