Anyone got impala working?

2

I am evaluating for my company if impala can be used on jasperreport.

I have tried iReport, jaspersoft studio and JasperServer on the latest 5.2 download for Impala connection.

The result is,

JasperSoft studio takes the connection url jdbc:hive://10.0.0.5:21000/default and tested successful. However on getting the meta data it returns nothing.

iReport does not even take the above url. But they both works for hive connection on port 10000.

JasperServer failed such connection as data source using hadoop Hive data source

so I added a custom JDBC driver for impala given url like jdbc:hive2://10.0.0.5:21050/;auth=noSasl and use org.apache.hive.jdbc.HiveDriver as jdbc driver. but it leads to a jar conflict. I had to hack some jar to resolve this. Then the connection test sucessful. But on building a domain using this connection, it throws error, "Cannot get a connection, pool exhausted". The exception is not follow:

org.apache.commons.dbcp.SQLNestedException: Cannot get a connection, pool exhausted
at org.apache.commons.dbcp.PoolingDataSource.getConnection(PoolingDataSource.java:103)
at com.jaspersoft.commons.semantic.metaapi.impl.jdbc.BaseJdbcMetaDataFactoryImpl.getConnectionFromDataSource(BaseJdbcMetaDataFactoryImpl.java:152)
at com.jaspersoft.commons.semantic.metaapi.impl.jdbc.BaseJdbcMetaDataFactoryImpl.getDatasourceProperties(BaseJdbcMetaDataFactoryImpl.java:223)
...
Caused by: java.util.NoSuchElementException: Could not create a validated object, cause: Method not supported
at org.apache.commons.pool.impl.GenericObjectPool.borrowObject(GenericObjectPool.java:806)
at org.apache.commons.dbcp.PoolingDataSource.getConnection(PoolingDataSource.java:95)

So anyone got Impala working? I am hoping it can work. otherwise have to look at pentaho for Impala integration.

 

planar's picture
13
Joined: May 12 2010 - 3:25pm
Last seen: 4 years 11 months ago

I am seeing EXACTLY the same thing.  DId you every resolve this?

daviesd - 5 years 6 months ago

No, we went to different route.

planar - 5 years 6 months ago

3 Answers:

0

Hey,

We can help it out if you have requirements. We have an expertise in BI since 8+ years.

You can reach me at mohilchhabra.ubs@gmail.com/mohil_chhabra@yahoo.com.

Regards

 

 

mohilchhabra.ubs's picture
Joined: Oct 16 2013 - 2:04am
Last seen: 5 years 10 months ago
0

Support for Impala before 5.5 was pretty much a "headache". I suggest to try 5.5 or 5.6 that have better support for Impala.

Make sure you use this connection string when creating a Hadoop-Hive Data Source for Impala: jdbc:hive2://10.0.0.5:21050/;auth=noSasl

rudygodoy's picture
398
Joined: Nov 24 2012 - 3:52pm
Last seen: 4 years 2 weeks ago
0

An update on this, I downloaded Jasper report server 5.6.1 and it came with CDH5 Hive Impala driver. But this time I tried to hook up with IBM BigSQL 3 and it works!

planar's picture
13
Joined: May 12 2010 - 3:25pm
Last seen: 4 years 11 months ago
Feedback