Create new organization hangs in JasperReports Server

I install a canned repository at several clients sites and then update it, which has been working fine for a few years, but since our starting library has grown and changed, and since I often end up creating a few organizations (multi-tenancy) at each client site, I decided to update our "/organizations/org_template/" folder to also contain a copy of our standard starting library, in hopes that when I create a new organization, it will start out with a copy of this Folder Template, ideally changing any cross-dependencies to keep them local (like making the queries reference the copied, local version of the data source (which I have to change after the copy), changing the input controls to point to the local copies of  queries, and changing reports to look at the local data source and any input links to point to local copies of input controls).  BUT...after I did that, I went into JasperReports Server (V3.7.1.1, by the way) and tried to create a new organization to see if all that would work, and it just hung.  I looked through catalina.out, and it looks like an Access is denied (with of course everal lines afterwards, one of which is "at com.sun.proxy.$Proxy13.saveFolder (Unknown Source)".  I'm logged on as superuser and have aministration authority over every folder and file in the repository.  I even tried deleting all the reports, input controls, queries, and folders that I had created in the template folder, but I still get the same error in the log when I try to create a new organization.  Any ideas?

cbarlow3's picture
Joined: Mar 4 2010 - 8:59am
Last seen: 1 year 2 months ago

0 Answers:

No answers yet