JasperSoft Studio: How to define a JNDI Data Source?

Jaspersoft Community 'Read-Only' as of July 8, 2022

Transition to New TIBCO Community Just Weeks Away

You can still search, review wiki content, and review discussions in read-only mode. Please email community@tibco.com with questions or issues requiring TIBCO review or response.

Hi,

My reports on JasperReports Server use a JNDI Data Source defined into this file

C:\Program Files\jasperreports-server-5.1\apache-tomcat\conf\Catalina\localhost\jasperserver-pro.xml

Developing with iReport I use a JDBC connection instead of JNDI to test the reports.

Now I'm trying to switch to JasperSoft Studio.

When I use JasperSoft Studio to try to open any Input Control placed on the server, JasperSoft Studio does not found JNDI Data Source and throws this exception:

java.lang.Exception: 1 - Name <JNDI_NAME> is not bound in this Context
    at com.jaspersoft.ireport.jasperserver.ws.WSClient.get(WSClient.java:274)
    at com.jaspersoft.studio.server.protocol.soap.SoapConnection.get(SoapConnection.java:74)
    at com.jaspersoft.studio.server.protocol.ProxyConnection.get(ProxyConnection.java:52)
    at com.jaspersoft.studio.server.editor.input.InputControlsManager.getInputControls(InputControlsManager.java:120)
    at com.jaspersoft.studio.server.editor.ReportRunControler$1.run(ReportRunControler.java:81)
    at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)

If I manually add the JNDI Data Source to "Data Adapters" using "Import From Workspace" option and then I test it, this exception is thrown:

javax.naming.NameNotFoundException; remaining name 'env/<JNDI_NAME>'
//See attached image

So how can I configure JNDI Data Source into JasperSoft Studio?

federico.cattozzi's picture
Joined: Sep 22 2009 - 4:34am
Last seen: 8 years 3 months ago

I'm getting same issue here, just AIX instead of Windows and Websphere instead of Tomcat. Any idea about how to solve it?

joseluis.delacruz - 8 years 4 months ago

Every Java Application Server has an own way to configure JNDI data source, you have to use the Websphere's way. In alternative you can try to write JNDI data source configuration into .../jasperserver/META-INF/context.xml

federico.cattozzi - 8 years 4 months ago

Hi,

I've tried on Tomcat and same issue. I've defined JNDI connection on Tomcat's web.xml, restarted and the same result, error.

 

joseluis.delacruz - 8 years 4 months ago

0 Answers:

No answers yet
Feedback
randomness