Problems while running jasperserver on ubuntu 12.04

0
Hi, We have downloaded the latest version of jasperserver community edition (5.1.0) and installed it on linux (Ubuntu 12.04). At the end of installation we run the jasper server and it runs successfully without any error, However, when we stop the services using ctlscript.sh, and restart the machine then the jasper server doesnt start. We start the services using ctlsript.sh and all the services start sucessfully. We manage the get the tomcat homepage at http://localhost:8080, but when we enter http://localhost:8080/jasperserver, it gives 404 error. (FYI: We are running the setup on a large AWS EC2 instance) Regards, Reyner Dsouza
rynrdsouza's picture
Joined: Jun 26 2013 - 10:35pm
Last seen: 6 years 3 months ago

2 Answers:

0

Hi Reyner - You are starting and stopping JasperReports Server correctly. If you want JasperReports Server to start as a service (rather than using ctlscript.sh), you can find an example of how to do that in the jasperreprots-server-5.1/scripts/linux directory.

It's hard to say what is causing the 404 error. If Tomcat loads, then JasperReports Server should be running. My best suggestion right now is to check the log files. This article provides more detail than what you need, but it gives you a good understanding of where the files are located: http://community.jaspersoft.com/wiki/how-produce-clean-log-files-troubleshooting.

I hope this helps.

Mary Flynn

Jaspersoft

mmflynn's picture
1646
Joined: Sep 19 2006 - 5:43am
Last seen: 6 years 2 months ago
0

I'm getting the same here... Tomcat is running ok, but I get 404 whenever I try http://localhost:8080/jasperserver . I'll be checking log files...

Regards,

Lucas Andrade.

andrattis88's picture
Joined: Aug 16 2013 - 6:41am
Last seen: 2 years 8 months ago
Feedback
randomness