Single sign on jtds SSO works in first data connection test then fails

0

I have installed jasperstudio 5.1 and set up a data connection to SQL Server

Using the jTds driver with single sign on.

When I run a test in the conenction the first time it is successful, any subsequent tests or attempts at a conenction fails with a missing SSO library

If i run Dbvisualizer with the same jtds configuration it works without any issue.

Any thoughts

I am running on windows 7 32bit fully patched

 

 

paul_27's picture
Joined: Nov 15 2012 - 2:11pm
Last seen: 1 week 9 hours ago

1 Answer:

0
Hi Paul,
I committed a "new" version of the driver used in JSS. We are now using the last 1.2.8 (released on 2013-06-08). Before we were wrongly using 1.3.0.
Unfortunately 1.3.x line of drivers requires Java 7 or higher. Since we are using Java 6 as minimum required environment it's better to stick to the 1.2.x versions.
I tested with an local installation of SQL Server 2008 and everything worked fine, also report previewing.
 
I verified that DBVisualizer (at least the last 9.0.8) is using the 1.2.7 version. You said that it was working fine for you. Then using the last one from 1.2.x line of drivers should be fine.
 
You will be able to test and see if everything works fine starting from next version of JSS.
 
Best regards, 
Massimo.
mrabbi's picture
7930
Joined: Oct 31 2011 - 9:20am
Last seen: 2 days 11 hours ago
Feedback
randomness