Where can I download the Workbench / Can I use Pentaho Worbench

0

Hi there.

I tried to use a mondrian schema which i created in Pentaho Workbench. It contains three cubes with shared dimensions and a virtual cube.

I tried to use it in iReports. I added a JDBC Connection to a MySQL Database which contains the data of the cubes in form of star-schemas. Then I added an Mondrian Olap connection which makes use of the before created JDBC connection and selcted the XML file which contains the Olap Schema.

Connection works but when I use the Report Wizard and it comes to step 4. "Fields" there is nothing to select. The schema file workes for my in the Pentaho BI-Server and Pentaho Schema Workbench.

So my questions are:

  1. Is there a difference between Pentaho Mondrian Schemas and Jasper Mondrian Schemas? Or does iReport maybe not support shared dimensions or virtual cubes?
  2. I can't find a download link for Jasper Olap Workbench anywhere here?! Where is it?

Thanks & Regards

Heisenberg

 

EDIT: The schema is working for Jasper Reports Server OLAP view. Still can't use it in iReports or Report Designer. Any suggestions?

Heisenberg's picture
Joined: May 16 2013 - 12:22am
Last seen: 6 years 3 months ago

2 Answers:

0

You can get the OLAP workbench form here: http://sourceforge.net/projects/jasperserver/files/JasperServer/JasperServer%204.0.0/

Is esentialy the same as the standard mondrian OLAP workbench but matches the mondrian engine that is included in JasperReports Server. 

You have the documentation about Jaspersoft OLAP here: http://community.jaspersoft.com/documentation/jaspersoft-olap-users-guide

marianol's picture
4575
Joined: Sep 13 2011 - 8:04am
Last seen: 10 months 3 weeks ago

Note: If you have a comercial Jasperserver license you can download the OLAP workbench from http://support.jaspersoft.com

marianol - 6 years 3 months ago

Thanks for your answer. I think the document you posted is not very helpfull when it comes to reporting using OLAP.

However, I managed using my Mondrian Schema with iReports via a XML/A Connection. But still in the Reports Wizard there are no Fields to select. I don't know if it is a bug? Doesn't matter if I use the virtual cube of my schema, or a ordinary cube. I can use the fields if I build the report manually.

Heisenberg - 6 years 3 months ago
djohnson53 - 5 years 1 month ago
0

I found the 4.0.0 in this forum : https://community.jaspersoft.com/questions/823877/jaspersoft-olap-designer

But in my opinion Pentaho Schema Workbench is better to design Mondrian schemas : https://sourceforge.net/projects/pentaho/files/Pentaho%208.2/client-tools/psw-ce-8.2.0.0-342.zip.sum/download

 

arnaudsimon091's picture
Joined: Nov 26 2018 - 12:25pm
Last seen: 1 week 4 days ago
Feedback
randomness