Connecting iReport 5 to JasperReports Server 5 repository

0

I am trying to connect from iReport 5 to JasperReports Server 5 repository. Whenever I am trying to connect to the repo I get " Error: (401) Unauthorized " message. Our installation of jasperserver is uintegrated with cas therefore I need to set up dual authentication to be able to utilize jasperserver plugin.

I have tried to set authentication as outlined in http://community.jaspersoft.com/wiki/creating-second-jasperreports-server-authentication-manager-use-ireport-designer wiki page. I found that this approach doesn't work for jasperserver 5 at all. Server won't even start up. I have solved start up issue by adding this line bean.basicProcessingFilter2=mtBasicProcessingFilter to js.spring.properties but I still can't use plugin from iReport.

Any ideas how to set up for dual authentication?

Thank you

svager's picture
2
Joined: Apr 11 2011 - 7:42am
Last seen: 6 years 1 month ago
I am facing the same issue while adding new jasperreports server authentication manager for "/services". Any one got this working finally? I got this error in catalina.out: org.springframework.beans.factory.BeanDefinitionStoreException: Invalid bean definition with name 'filterChainProxy' defined in ServletContext resource [/WEB-INF/applicationContex t-security-web.xml]: Could not resolve placeholder 'bean.basicProcessingFilter2'
Aditya S - 6 years 3 months ago

Hi,

I'm facing this issue in JasperServer 5.2 and iReport 5.2.

Have you found any resolution?

 

Sathya.sk - 5 years 1 month ago

0 Answers:

No answers yet
Feedback
randomness