Empty reports on fresh installation of JasperServer?

0

Hi All,

I've just installed JasperServer into an existing Tomcat. My problem is that everything is functional except the reporting under Library: all of them results in an almost blank screen.

Unfortunately the logs are empty. Any hints where to start looking around about the issue?

Thanks in advance!

richard.legendi's picture
Joined: Jan 16 2013 - 7:32am
Last seen: 6 years 7 months ago
Richard, did you solved it? I'm facing same issue..
karel.balac - 6 years 7 months ago
Well, sort of. Actually, I wanted put JasperServer into a Liferay bundled Tomcat. I wasn't succesful in integrating these tools, but as the Server Admin Guide suggested in the docs folder of JasperServer, the official way to do this is to use **two** Tomcat installations. That was the best solution I was able to come up with. However, a hint that might help you out: I got a warning on the logs about the *Context is read-only*. I tried to merge the `conf/context.xml` file of Tomcat and the JasperServer but then even the first page of JasperServer didn't load. I might have misconfigured something else too (I was trying recklessly to put things together and installed several other webapps and configured everything I found, etc.), but maybe you'll have a bit more luck with this. Hope this helps.
richard.legendi - 6 years 7 months ago
ok. thanks for info
karel.balac - 6 years 7 months ago

4 Answers:

0

I am guessing that you are talking about the sample reports.  Can you tell if there is any data in the tables that it is trying to pull the data from?  Maybe something went wrong with the load of the sample data.  Is this specific to the library view?  Do the reports work from other views, such as the repository view?  I have not seen this before - empty database tables would be my best guess.

mgeise's picture
19558
Joined: Mar 5 2007 - 6:18am
Last seen: 1 week 3 days ago

Yes, about the sample reports (as you can see the name of the query on the screenshot is Accounts Reports). I believe the data import was successful because both demo tables (*sugarcrm, foodmart*) is populated, I can use them in the embedded JPivot tool. The import showed some errors for the *foodmart* table, but since all the sample reports are empty I suspect an other problem here. It seems the reports do not work from the repository view.

richard.legendi - 6 years 8 months ago
1

Check if the JDBC and the JNDI connection to the sample database is working properly. Since you installed in your own tomcat it may be a JNDI config issue.

marianol's picture
4675
Joined: Sep 13 2011 - 8:04am
Last seen: 11 months 3 weeks ago

Good idea, I'll check it.

richard.legendi - 6 years 8 months ago

I've checked all connections and pressing the "Test" button said they are all passed. I'll double-check all my settings.

richard.legendi - 6 years 8 months ago
1

Here's some of the things that I do when I'm having trouble with tomcat. Shutdown tomcat, delete files: 

tomcat/conf/Catalina/Localhost/*.xml (if there are any jrs related datasource files in here) (tomcat will recreate them)

tomcat/logs/*.*

tomcat/work/Catalina/localhost

tomcat/temp/*.*

It looks to me that there is some sort of display error. Because the report unit is present - and you obviously clicked on it to try and display the report. 

So, the trick I think is to try and get some error information in the logs:

tomcat/logs/catalina.out

tomcat/webapps/jasperserver/WEB-INF/logs/jasperserver.log 

And hopefully there is some info after the cleanup

tkavanagh's picture
3163
Joined: Jul 7 2006 - 8:54am
Last seen: 5 years 3 weeks ago
1

To try to get more information, one thing to try would be to edit tomcat/webapps/jasperserver/WEB-INF/log4j.properties and change "log4j.rootLogger=ERROR, stdout, fileout" to "log4j.rootLogger=DEBUG, stdout, fileout" (this puts the jasperserver logger in "spew mode").  Restart tomcat (or at least restart jasperserver webapp) and monitor tomcat/webapps/jasperserver/WEB-INF/logs/jasperserver.log (if it doesn't exist, you'll want to "touch" the file to create one -- for some reason Jasper Server won't create a log if the file doesn't exist...no clue why).

HTH...

andy.hill's picture
Joined: Jan 14 2013 - 6:55pm
Last seen: 5 years 11 months ago
Feedback