Error when adding post-data to a Jasper Server Report URL

0

Hello, I have been having an issue adding post-data into a report URL ever since upgrading from Jasper Server 4.21 to 4.7

Normally my report url (the ending) looks something like this %2FReports%2Freport&EmployeeName=JohnSmith&j_username=jasperadmin&j_password=jasperadmin&decorate=no

I have a matching parameter and input controls and the report runs fine with I run it from the URL (it can only be run from the URL because the parameter is hidden and mandatory) 

 

 In our app, we add the parameter in post-data so the user cannot see the whole URL. But ever since we upgraded to 4.7 the reports are returning as empty and can only be run directly from the URL. I know it isn't a problem on our app side because I tested it with 4.21 and the reports run from the app again like normal. I then tried upgrading to 5.0 and setting up the same reports etc and again the reports would only run directly from the URL, and it gave the error "Specified page not found" when it ran from our app. (didnt give that error in 4.7) I know Jasper Server has changed it's input controls since 4.5 and I have a feeling it may be related to that.

 

But ANY help would be GREATLY appreciated!!! thanks so much in advance!

ryanmorse's picture
Joined: Feb 14 2012 - 10:38pm
Last seen: 5 years 3 months ago

0 Answers:

No answers yet
Feedback
randomness