Error running /opt/jasper/apache-ant/bin/ant import-ce

0

 

cannot open http://localhost:8080/jasperserver after install
 
---------------------------------------------------------------------------
Please wait while Setup installs JasperReports Server CP 4.7.0 on your computer.
 
 Installing
 0% ______________ 50% ______________ 100%
 #########################################
 
Warning: Problem running post-install step. Installation may not complete 
correctly
 Error running /opt/jasper/apache-ant/bin/ant import-ce 
-DimportFile=install_resources/export/js-catalog : 
BUILD FAILED
/var/lib/postgresql/jasper/buildomatic/bin/import-export.xml:255: The following 
error occurred while executing this line:
/var/lib/postgresql/jasper/buildomatic/bin/import-export.xml:158: Java returned: 
255
 
Total time: 15 seconds
Press [Enter] to continue :
 
----------------------------------------------------------------------------
Setup has finished installing JasperReports Server CP 4.7.0 on your computer.
 
Opt-in for JasperServer Heartbeat
Help us build better products by opting in
 
For more information please visit: 
 [Y/n]: 
 
 
please help
 
 
root@google:~# cat /etc/hosts
127.0.0.1 localhost.localdomain localhost
::1 localhost ip6-localhost ip6-loopback
 
 

 

root@google:/opt/jasper# telnet localhost 5432
Trying ::1...
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
^]q
 
telnet> q
Connection closed.
LOG:  incomplete startup packet
root@google:/opt/jasper# telnet localhost 8080
Trying ::1...
Connected to localhost.localdomain.
Escape character is '^]'.
 
awan.atmadja's picture
Joined: Dec 5 2012 - 6:02am
Last seen: 7 years 9 months ago

1 Answer:

1

i fix this one by myself help by god

 

what you need to do

 

1. change you hostname, using vi or vim and then cat your hostname to be something like this

 

root@localhost:~# cat /etc/hostname 
localhost
 
2. because i am using debian i run hostname update script
 
root@localhost:~# /etc/init.d/hostname.sh
 
3. signout and then sign in again
 
4. make sure your /etc/host like below
 
root@localhost:~# cat /etc/hosts
127.0.0.1 localhost.localdomain localhost
::1 localhost ip6-localhost ip6-loopback
 
5. Resintall your jasperserver, uninstall first and then install again
 
root@localhost:~# ./jasperreports-server-cp-4.7.0-linux-x64-installer.run 

you should be ok by now and it's magically fix it self

awan.atmadja's picture
Joined: Dec 5 2012 - 6:02am
Last seen: 7 years 9 months ago
Feedback
randomness