Unable to update to latest JS-Studio 1.3.1

1

The eclipse update process fails.  I am updating from an existing install of JR-S.

An error occurred while collecting items to be installed
session context was:(profile=SDKProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.eclipse.nebula.cwt,0.9.0.201210100641
No repository found containing: osgi.bundle,org.eclipse.nebula.widgets.cdatetime,0.14.0.201210100

rlfisher's picture
196
Joined: Oct 24 2008 - 9:56am
Last seen: 8 months 1 week ago
mrabbi - 6 years 11 months ago

3 Answers:

0

Hi it looks to me that it can't contact the suggested update sites for Nebula Widgets.
This could be caused by your current configuration.
Could please give a look at this Issue on the tracker: http://community.jaspersoft.com/jaspersoft-studio/issues/2530

Some guys had similar problems.
In particular give a look to my comment #5.
"Contact all update sites during install to find required software"  is probably not enabled. 

Best regards,
Massimo.

mrabbi's picture
7930
Joined: Oct 31 2011 - 9:20am
Last seen: 2 days 11 hours ago

Hi Massimo -

That option was enabled, following some other posts I cleared it, restarted eclipse, and checked the setting again.  Still not updating. 

An error occurred while collecting items to be installed
session context was:(profile=SDKProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.eclipse.nebula.cwt,0.9.0.201210232241
No repository found containing: osgi.bundle,org.eclipse.nebula.widgets.cdatetime,0.14.0.201210232241

In "available software sites" there is a long list of sites, about a dozen are checked, corresponding to the things I have installed (subclipse, python, JS Studio, etc.)

rlfisher - 6 years 11 months ago
0

Hi Massimo -

The first one was present but not checked, the other two were checked.  I checked the first one and got the same error as before.

rlfisher's picture
196
Joined: Oct 24 2008 - 9:56am
Last seen: 8 months 1 week ago
Have not been able to resolve this. Going back to iReport.
rlfisher - 6 years 11 months ago
0

I also had the same problem with Nebula Widgets. I installed them from the MarketPlace and tried updating to JasperStudio 1.31. Now I get the exception:

 

An error occurred while installing the items
session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=[R]com.jaspersoft.studio.data 1.1.2 --> [R]com.jaspersoft.studio.data 1.3.1, action=).
Failed to prepare partial IU: [R]com.jaspersoft.studio.data 1.3.1.
 
I am using Juno. Any ideas??
mrobinson's picture
Joined: Oct 3 2006 - 8:26am
Last seen: 1 year 6 months ago
I deleted the old version 1.1.2. Tried reinstalling 1.3.1 and got the dependency exception about apache.commons.pool. I installed that jar file into the plugins folder of Eclipse, restarted, and tried reinstalling 1.3.1. This time it installed without error. However, when I open a pre-existing report in design view, only the lines and outlines of text expressions show up. What's up with that?
mrobinson - 6 years 11 months ago
Created a new report and the design display was the same as a pre-existing one. That is, adding, for example, static text is invisible except for the outline.
mrobinson - 6 years 11 months ago
For Juno 4.2 users like me, here is a link from the JasperReports people about installing & testing JasperStudio 1.3.1 http://sourceforge.net/projects/jasperstudio/files/DevelopersInfo/juno_42/
mrobinson - 6 years 11 months ago
Feedback
randomness