Jasper Report Server 4.7.0 and font extension installation problem

0

Dear all,

I think many people got the same problem and too hard to find the way to solve it.

I deployed Jasper Report Server on Glassfish 3.0, JRS works normally. My server is CentOS 5, and Microsoft True Type fonts are installed in /usr/share/fonts/msttcorefonts/ folder. All ttf files are copied to JAVA_HOME/jre/lib/fonts folder too.

I used iReport 4.7.0 to export the font extension jar files and copy them to WEB-INF/lib in JRS application's folder in Glassfish.

The report are showing in browser OK, but when export to PDF, Unicode characters are missed. In Jasper Report XML (JRXML) I double check "PDF Embedded" propertie is checked.

I also tried to add font extension jar files into repository and link resource to Jasper Report. But the PDF export still missed unicode characters.

I really don't know how to solve this problem.

Please help me. Thanks in advanced!

hanviet2003's picture
Joined: Oct 5 2012 - 8:28pm
Last seen: 6 years 10 months ago
I solved problem. Missed tag: Identity-H in exported XML. However, I created manual based on font extension example. I don't try again with exported extension jar file.
hanviet2003 - 6 years 10 months ago
Are you saying that there is bug in the exporting of a font extension from iReport 4.7.0? If so, can you please log it in the tracker. Thanks!
mgeise - 6 years 10 months ago

0 Answers:

No answers yet
Feedback
randomness