Problem with Different User Types

0

Downloaded the mobile app, plugged in the URL, username, password etc. And it works, if I use jasperadmin as the user and you can see the entire repository. The problem is when you want the user to go to only one "organization". Tried the following steps:

1. Created a Demo Organization on the server (4.2.1, Commercial)

2. Created a Demo user with access rights of ROLE_USER, ROLE_ADMINISTRATOR for the Demo organization.

3. Plugged in all the required fields in the mobile app.

4. In the organization field, put in Demo ( the org I just created)

If you try to login, no error messages, but empty repository shows up. I have even tried putting in /organizations/Demo/ in the org field, but nothing seems to be working. Any idea what is going on?

ksnair's picture
2
Joined: Jan 27 2012 - 8:13am
Last seen: 5 years 7 months ago

2 Answers:

0

 Try putting in the user name as user|organization. Kind of goofy, but it works for me. The SOAP web service documentation discusses this even though the app is using REST.

bhoman's picture
3
Joined: Nov 10 2011 - 9:29am
Last seen: 7 years 9 months ago
0
I just logged this as a bug
ernestoo's picture
8164
Joined: Nov 29 2010 - 11:59am
Last seen: 1 year 10 months ago
Feedback