Unable to split Excel output into multiple sheets

0

Hi guys,

after trying to create multiple Excel sheets in iReport 3.7.4, i have not found out how to get it working. The export property "net.sf.jasperreports.export.xls.one.page.per.sheet" has been set to true in the jrxml file as shown below.

<property name="net.sf.jasperreports.export.xls.one.page.per.sheet" value="true"/>

I have ticked the "Ignore pagination" checkbox under the report properties. As i want each group header to be on a new sheet so i have added the page break element inside the group footer band. I have also ticked the "Start on a new page" checkbox for the group header. For the subreport inside the report, i have also ticked the same property "Start on a new page".

The result that comes out is that the spacing between each group header is wider instead of on separate sheets. Any ideas on what is needed or to be corrected to make the multiple sheets appear?

Thanks for your replies.

errol's picture
5
Joined: Sep 15 2011 - 5:43am
Last seen: 5 years 11 months ago

2 Answers:

0
Do you have "One Page Per Sheet" option checked in IReport export options? Seems as if IReport overrides/ignores export options set in jrxml and only uses what's in Tools --> Options --> Export settings.
darth_fader's picture
Joined: Mar 7 2010 - 9:45pm
Last seen: 7 min 45 sec ago
0

Hi guys,

if the "One page per sheet" option in the iReport Excel export options is checked, then multiple sheets will appear. However the sheets are not separated by the group header. They are instead separated based on the length of the page. This is still not correct as it should split by the group header.

Is there any way to force iReport to page break according to the group header & not depend on the iReport settings? As the report will be generated from outside of iReport so it will not work if it's only set for iReport.

Thanks for your replies.

errol's picture
5
Joined: Sep 15 2011 - 5:43am
Last seen: 5 years 11 months ago

An ugly work around is to set the length of the page to a very high height. Go to Format -> Page Format... in Height enter 500 inches (36,000 pixels, 1270 cm, or 12,700 mm). If you still have problems double this value and double again if required.

techogre - 3 years 2 months ago

Hi all, By increasing the height of the report , we can achieve this but the PDF format of the report won't be proper. Is there any alternate solution? Kindly help ,
Thanks in advance,

puranik01 - 2 years 9 months ago
Feedback