[SOLVED] jasperserver 4.0.0 source build fails on add-jbdc-driver target

0

 add-jdbc-driver:

     [echo] maven.home = /usr/local
 
BUILD FAILED
/home/jhelfman/ports/databases/jasperserver/work/jasperreports-server-cp-4.0.0-src/jasperserver/buildomatic/bin/dev.xml:157: The following error occurred while executing this line:
/home/jhelfman/ports/databases/jasperserver/work/jasperreports-server-cp-4.0.0-src/jasperserver/buildomatic/bin/dev.xml:91: /usr/local/boot does not exist.
 
Total time: 0 seconds
*** Error code 1
 
This is using the downloaded maven repository made available on this release cycle. I have the maven repository unzipped in my home directory as ~/.m2/repository/
 
below is my default_master.properties file.
 
Any help is appreciated!
Thanks
jgh
Code:
appServerType = tomcat5
appServerDir = /usr/local/tomcat5.5
dbType = mysql
dbUsername = root
dbPassword = password
dbHost = localhost
maven = /usr/local/bin/mvn
js-path = /home/jhelfman/ports/databases/jasperserver/work/jasperreports-server-cp-4.0.0-src/jasperserver
js-repo-path = /home/jhelfman/ports/databases/jasperserver/work/jasperreports-server-cp-4.0.0-src/jasperserver-repo


Post Edited by jgh at 02/18/2011 19:22
jgh's picture
jgh
315
Joined: Aug 27 2010 - 4:24pm
Last seen: 5 years 3 months ago

30 Answers:

0

It looks like there is an assumption about the folder structure of maven in the buildomatic/bin/dev.xml ant script.

                <classpath>
                  <fileset dir="${maven.home}/boot">
                    <include name="*.jar" />
                  </fileset>
                  <fileset dir="${maven.home}/lib">
                    <include name="*.jar" />
                  </fileset>
                </classpath>

This is where the plexus-classworlds-2.4.jar (maven 3.0.2) or classworlds-1.1.jar (maven 2.2.1) is found.

Are you able to get around this problem... ? I'm not sure what to think about this issue... do you know where your maven jars end up getting put in place?

 

tkavanagh's picture
2773
Joined: Jul 7 2006 - 8:54am
Last seen: 4 years 9 months ago
0

 I was trying to work around this issue in patching dev.xml, which I will probably need to do.

 

Here is the log for jasperserver 3.5.0 and where it installs things now. Have a look at that target, and any other applicable targets:

http://pointyhat.freebsd.org/errorlogs/amd64-7-full-logs/jasperserver-3.5.0.log

I will paste below, however please do look at the log, as well.

Code:
add-jdbc-driver:
     [exec] [INFO] Scanning for projects...
     [exec] [INFO] Searching repository for plugin with prefix: 'install'.
     [exec] [INFO] ------------------------------------------------------------------------
     [exec] [INFO] Building Maven Default Project
     [exec] [INFO]    task-segment: [install:install-file] (aggregator-style)
     [exec] [INFO] ------------------------------------------------------------------------
     [exec] [INFO] [install:install-file {execution: default-cli}]
     [exec] [INFO] Installing /work/a/ports/databases/jasperserver/work/jasperserver-3.5.0-src/jasperserver/buildomatic/conf_source/db/mysql/jdbc/mysql-connector-java-5.1.5.jar to /root/.m2/repository/mysql/mysql-connector-java/5.1.5/mysql-connector-java-5.1.5.jar
     [exec] [INFO] ------------------------------------------------------------------------
     [exec] [INFO] BUILD SUCCESSFUL
     [exec] [INFO] ------------------------------------------------------------------------
     [exec] [INFO] Total time: 8 seconds
     [exec] [INFO] Finished at: Tue Feb 01 01:27:57 GMT 2011
     [exec] [INFO] Final Memory: 7M/50M
     [exec] [INFO] ------------------------------------------------------------------------
 
BUILD SUCCESSFUL
Total time: 12 seconds</td></tr></tbody></table>
jgh's picture
jgh
315
Joined: Aug 27 2010 - 4:24pm
Last seen: 5 years 3 months ago
0

 I have maven version 2.2.1, but I don't see the jar you are speaking of from the repository zip.

Code:
[jhelfman@eggman /root/.m2/repository]$ find . -name 'classworlds*'
./classworlds
./classworlds/classworlds
./classworlds/classworlds/1.1-alpha-2/classworlds-1.1-alpha-2.pom.sha1
./classworlds/classworlds/1.1-alpha-2/classworlds-1.1-alpha-2.pom
./classworlds/classworlds/1.1/classworlds-1.1.pom.sha1
./classworlds/classworlds/1.1/classworlds-1.1.pom
</td></tr></tbody></table>
jgh's picture
jgh
315
Joined: Aug 27 2010 - 4:24pm
Last seen: 5 years 3 months ago
0

Wait, I think I see what the issue is. I got the same error as you when I was building on ubuntu 10.10. I installed mvn using apt-get.

The mvn binary is found here: /usr/bin/mvn

But there is also this location which has the expected maven folder structure:

  /usr/share/maven2

      bin

      boot

      lib

So if in my default_master.properites I set:

  maven = /usr/share/maven2/bin/mvn

Then this worked for me.

 

 

tkavanagh's picture
2773
Joined: Jul 7 2006 - 8:54am
Last seen: 4 years 9 months ago
0

 I updated it and now I have this error. Here is my properties file ( i added additional properties with same value based on errors coming back):

appServerType = tomcat5

appServerDir = /usr/local/tomcat5.5

dbType = mysql

dbUsername = root

dbPassword = password

dbHost = localhost

maven = /usr/local/share/java/maven2/bin/mvn

js-base-path = /home/jhelfman/ports/databases/jasperserver/work/jasperreports-server-cp-4.0.0-src/jasperserver

js-path = /home/jhelfman/ports/databases/jasperserver/work/jasperreports-server-cp-4.0.0-src/jasperserver

repo-path = /home/jhelfman/ports/databases/jasperserver/work/jasperreports-server-cp-4.0.0-src/jasperserver-repo

js-repo-path = /home/jhelfman/ports/databases/jasperserver/work/jasperreports-server-cp-4.0.0-src/jasperserver-repo

Code:
init-source-paths:
     [echo]  
     [echo] Property values (in dev.xml: init-source-paths): 
     [echo]   js-path = /home/jhelfman/ports/databases/jasperserver/work/jasperreports-server-cp-4.0.0-src/jasperserver
     [echo]   js-pro-path = ${js-pro-base-path}
     [echo]   repo-path = /home/jhelfman/ports/databases/jasperserver/work/jasperreports-server-cp-4.0.0-src/jasperserver-repo
     [echo]  
 
add-jdbc-driver:
     [echo] maven.home = /usr/local/share/java/maven2
     [java] [INFO] Scanning for projects...
     [java] [INFO] ------------------------------------------------------------------------
     [java] [ERROR] FATAL ERROR
     [java] [INFO] ------------------------------------------------------------------------
     [java] [INFO] Error building POM (may not be this project's POM).
     [java] 
     [java] 
     [java] Project ID: org.apache.maven:super-pom
     [java] 
     [java] Reason: Resolving expression: '${js-pro-path}': Detected the following recursive expression cycle: [js-pro-path] for project org.apache.maven:super-pom
     [java] 
     [java] 
     [java] [INFO] ------------------------------------------------------------------------
     [java] [INFO] Trace
     [java] org.apache.maven.reactor.MavenExecutionException: Resolving expression: '${js-pro-path}': Detected the following recursive expression cycle: [js-pro-path] for project org.apache.maven:super-pom
     [java] 	at org.apache.maven.DefaultMaven.getSuperProject(DefaultMaven.java:378)
     [java] 	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:275)
     [java] 	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
     [java] 	at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
     [java] 	at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
     [java] 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
     [java] 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
     [java] 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
     [java] 	at java.lang.reflect.Method.invoke(Method.java:597)
     [java] 	at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
     [java] 	at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
     [java] 	at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
     [java] 	at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
     [java] Caused by: org.apache.maven.project.ProjectBuildingException: Resolving expression: '${js-pro-path}': Detected the following recursive expression cycle: [js-pro-path] for project org.apache.maven:super-pom
     [java] 	at org.apache.maven.project.DefaultMavenProjectBuilder.buildStandaloneSuperProject(DefaultMavenProjectBuilder.java:332)
     [java] 	at org.apache.maven.project.DefaultMavenProjectBuilder.buildStandaloneSuperProject(DefaultMavenProjectBuilder.java:282)
     [java] 	at org.apache.maven.DefaultMaven.getSuperProject(DefaultMaven.java:373)
     [java] 	... 12 more
     [java] Caused by: org.apache.maven.project.interpolation.ModelInterpolationException: Resolving expression: '${js-pro-path}': Detected the following recursive expression cycle: [js-pro-path]
     [java] 	at org.apache.maven.project.interpolation.AbstractStringBasedModelInterpolator.interpolateInternal(AbstractStringBasedModelInterpolator.java:319)
     [java] 	at org.apache.maven.project.interpolation.StringSearchModelInterpolator$InterpolateObjectAction.traverseObjectWithParents(StringSearchModelInterpolator.java:263)
     [java] 	at org.apache.maven.project.interpolation.StringSearchModelInterpolator$InterpolateObjectAction.traverseObjectWithParents(StringSearchModelInterpolator.java:328)
     [java] 	at org.apache.maven.project.interpolation.StringSearchModelInterpolator$InterpolateObjectAction.run(StringSearchModelInterpolator.java:135)
     [java] 	at org.apache.maven.project.interpolation.StringSearchModelInterpolator$InterpolateObjectAction.run(StringSearchModelInterpolator.java:102)
     [java] 	at java.security.AccessController.doPrivileged(Native Method)
     [java] 	at org.apache.maven.project.interpolation.StringSearchModelInterpolator.interpolateObject(StringSearchModelInterpolator.java:80)
     [java] 	at org.apache.maven.project.interpolation.StringSearchModelInterpolator.interpolate(StringSearchModelInterpolator.java:62)
     [java] 	at org.apache.maven.project.DefaultMavenProjectBuilder.processProjectLogic(DefaultMavenProjectBuilder.java:990)
     [java] 	at org.apache.maven.project.DefaultMavenProjectBuilder.buildStandaloneSuperProject(DefaultMavenProjectBuilder.java:324)
     [java] 	... 14 more
     [java] Caused by: org.codehaus.plexus.interpolation.InterpolationCycleException: Resolving expression: '${js-pro-path}': Detected the following recursive expression cycle: [js-pro-path]
     [java] 	at org.codehaus.plexus.interpolation.StringSearchInterpolator.interpolate(StringSearchInterpolator.java:210)
     [java] 	at org.codehaus.plexus.interpolation.StringSearchInterpolator.interpolate(StringSearchInterpolator.java:124)
     [java] 	at org.apache.maven.project.interpolation.AbstractStringBasedModelInterpolator.interpolateInternal(AbstractStringBasedModelInterpolator.java:315)
     [java] 	... 23 more
     [java] [INFO] ------------------------------------------------------------------------
     [java] [INFO] Total time: < 1 second
     [java] [INFO] Finished at: Sat Feb 05 00:42:50 GMT 2011
     [java] [INFO] Final Memory: 1M/136M
     [java] [INFO] ------------------------------------------------------------------------
 
BUILD FAILED
/home/jhelfman/ports/databases/jasperserver/work/jasperreports-server-cp-4.0.0-src/jasperserver/buildomatic/bin/dev.xml:157: The following error occurred while executing this line:
/home/jhelfman/ports/databases/jasperserver/work/jasperreports-server-cp-4.0.0-src/jasperserver/buildomatic/bin/dev.xml:91: Java returned: 1
 
Total time: 2 seconds
*** Error code 1
 
Stop in /home/jhelfman/ports/databases/jasperserver.
*** Error code 1
 
Stop in /home/jhelfman/ports/databases/jasperserver.
</td></tr></tbody></table>
jgh's picture
jgh
315
Joined: Aug 27 2010 - 4:24pm
Last seen: 5 years 3 months ago
0
the repository, though, is under my home directory ~/.m2 (are the projects there?)
jgh's picture
jgh
315
Joined: Aug 27 2010 - 4:24pm
Last seen: 5 years 3 months ago
1

Ug, it looks like the js-pro-path (which you don't need, of course, for the CE build) is causing a problem. It looks like js-pro-path is set to a property value and this is causing a recursion. So, if you could set js-pro-path = /home (ie any value will do. But it might need to be resolved to a real path on your system).

Also, I'm wondering about your default_master.properties file.

Did you start by using one of the sample_conf files?

  <js-src>/jasperserver/buildomatic/sample_conf/source/mysql_master.properties

This way, the template that you start with has most properties set with default values. Just curious.

tkavanagh's picture
2773
Joined: Jul 7 2006 - 8:54am
Last seen: 4 years 9 months ago
2
I got it to work!


appServerType = tomcat5
appServerDir = /usr/local/tomcat5.5
dbType = mysql
dbUsername = root
dbPassword = password
dbHost = localhost
maven = /usr/local/share/java/maven2/bin/mvn
js-path = /home/jhelfman/ports/databases/jasperserver/work/jasperreports-server-cp-4.0.0-src/jasperserver
js-pro-path = /home/jhelfman/ports/databases/jasperserver/work/jasperreports-server-cp-4.0.0-src/jasperserver
js-repo-path = /home/jhelfman/ports/databases/jasperserver/work/jasperreports-server-cp-4.0.0-src/jasperserver-repo

It needed js-pro-path, as well.
I'll get back to you with anymore issues.
Thanks tony!
jgh's picture
jgh
315
Joined: Aug 27 2010 - 4:24pm
Last seen: 5 years 3 months ago
0
This is the problem I was refering to:
 
 [echo]   js-pro-path = ${js-pro-base-path}
 
Also, my .m2/repository is created by maven automatically (this is the "local repository").
tkavanagh's picture
2773
Joined: Jul 7 2006 - 8:54am
Last seen: 4 years 9 months ago
0

Ok, after install I noticed two things. One I was able to resolve, but by taking the default security file from 3.5.0

mysql -u root jasperserver < ~/jasperserver/work/jasperserver-3.5.0-src/jasperserver/./scripts/mysql/jasperserverCreateDefaultSecurity-mysql.sql

Is there a defaultsecurity file for mysql and postgresql for 4.0.0? Without this file, I couldn't get to the login screen for JasperServer.

The other issue I ran into is that the css for the webinterface doesn't appear to be working. Is there anything I can post that would help diagnose this issue other than what I have here:

Under my jasperserver directory I have a themes directory, but the page source is looking for _themes, so I renamed it. Under _themes it is looking for 5F5A58EA, so I renamed default to 5F5A58EA. 

Under this directory I have the following files:

[jhelfman@eggman /usr/local/tomcat5.5/webapps/jasperserver/_themes]$ find .

.

./pods_summer

./pods_summer/images

./pods_summer/images/button_action_jumbo_sprite.png

./pods_summer/images/button_action_primary_sprite.png

./pods_summer/images/logo.png

./pods_summer/images/button_capsule_sprite.png

./pods_summer/images/body_bkgnd.png

./pods_summer/images/search_sprite.png

./pods_summer/images/menu_primaryNav_sprite.png

./pods_summer/images/tabs_horizontal_sprite.png

./pods_summer/images/tabs_vertical_sprite.png

./pods_summer/images/frame_header_sprite.png

./pods_summer/images/disclosure_indicators_sprite.png

./pods_summer/overrides_custom.css

./reset.css

./5F5A58EA

./5F5A58EA/images

./5F5A58EA/images/frame_header_sprite.png

./5F5A58EA/images/panel_dialog_header_sprite.png

./5F5A58EA/images/button_options_sprite.png

./5F5A58EA/images/last-d.gif

./5F5A58EA/images/button_action_jumbo_primary_sprite.png

./5F5A58EA/images/last.gif

./5F5A58EA/images/menu_indicators_sprite.png

./5F5A58EA/images/panel_info_bkgd_edges_rl.png

./5F5A58EA/images/menu_context_bkgd_edges_tb.png

./5F5A58EA/images/next.gif

./5F5A58EA/images/logo.png

./5F5A58EA/images/panel_inlay_bkgd_edges_tb.png

./5F5A58EA/images/menu_dropDown_bkgd_edges_tb.png

./5F5A58EA/images/input_bkgd.png

./5F5A58EA/images/panel_inlay_bkgd.png

./5F5A58EA/images/panel_inlay_gradient_right.png

./5F5A58EA/images/button_action_jumbo_sprite.png

./5F5A58EA/images/login_welcome_ce_bkgd.jpg

./5F5A58EA/images/message_icons_sprite.png

./5F5A58EA/images/panel_info_system_bkgd_corners.png

./5F5A58EA/images/next-d.gif

./5F5A58EA/images/frame_background_sprite.png

./5F5A58EA/images/list_pressed_bkgd.png

./5F5A58EA/images/menu_context_bkgd_corners.png

./5F5A58EA/images/menu_primaryNav_sprite.png

./5F5A58EA/images/tabs_horizontal_sprite.png

./5F5A58EA/images/lists_sprite.png

./5F5A58EA/images/list_node_animation.gif

./5F5A58EA/images/panel_confirm_bkgd.png

./5F5A58EA/images/column_bkgd.png

./5F5A58EA/images/adhoc_toolbar_buttons_sprite.png

./5F5A58EA/images/panel_inset_bkgd_corners.png

./5F5A58EA/images/frame_bkgd_edges_tb.png

./5F5A58EA/images/panel_info_system_bkgd_edges_rl.png

./5F5A58EA/images/panel_info_bkgd_corners.png

./5F5A58EA/images/tabs_vertical_sprite.png

./5F5A58EA/images/menu_dropDown_bkgd_corners.png

./5F5A58EA/images/grid_20x20_bkgd.png

./5F5A58EA/images/body_bkgnd.png

./5F5A58EA/images/button_capsule_sprite.png

./5F5A58EA/images/grouper_sprite.png

./5F5A58EA/images/first.gif

./5F5A58EA/images/toolbar_bkgd.png

./5F5A58EA/images/panel_inset_bkgd_edges_tb.png

./5F5A58EA/images/panel_bkgd_edges_tb.png

./5F5A58EA/images/column_bkgd_edges_tb.png

./5F5A58EA/images/menu_context_bkgd_edges_rl.png

./5F5A58EA/images/prev-d.gif

./5F5A58EA/images/panel_inlay_bkgd_edges_rl.png

./5F5A58EA/images/menu_dropDown_bkgd_edges_rl.png

./5F5A58EA/images/frame_bkgd_corners.png

./5F5A58EA/images/menu_vertical_bkgd.png

./5F5A58EA/images/panel_sizer_sprite.png

./5F5A58EA/images/panel_inlay_gradient_left.png

./5F5A58EA/images/home_bkgd.png

./5F5A58EA/images/home_icons_sprite.png

./5F5A58EA/images/first-d.gif

./5F5A58EA/images/login_welcome_bkgd.jpg

./5F5A58EA/images/search_sprite.png

./5F5A58EA/images/panel_bkgd_corners.png

./5F5A58EA/images/frame_bkgd_edges_rl.png

./5F5A58EA/images/panel_info_bkgd_edges_tb.png

./5F5A58EA/images/tabs_horizontal_buttons_bkgd.png

./5F5A58EA/images/button_action_square_icons_sprite.png

./5F5A58EA/images/prev.gif

./5F5A58EA/images/header_primary_sprite.png

./5F5A58EA/images/button_action_primary_sprite.png

./5F5A58EA/images/button_action_sprite.png

./5F5A58EA/images/disclosure_indicators_sprite.png

./5F5A58EA/images/panel_inset_inset_bkgd.png

./5F5A58EA/images/panel_inlay_bkgd_corners.png

./5F5A58EA/images/cursor_copy.cur

./5F5A58EA/images/panel_widget_header_sprite.png

./5F5A58EA/images/cursor_copy.png

./5F5A58EA/images/wait_animation_large.gif

./5F5A58EA/images/gradient_frame.content.png

./5F5A58EA/images/panel_inset_bkgd_edges_rl.png

./5F5A58EA/images/sort_indicators_sprite.png

./5F5A58EA/images/panel_bkgd_edges_rl.png

./5F5A58EA/images/column_bkgd_edges_rl.png

./5F5A58EA/images/panel_info_system_bkgd_edges_tb.png

./5F5A58EA/images/column_bkgd_corners.png

./5F5A58EA/overrides_ie8.css

./5F5A58EA/pages.css

./5F5A58EA/controls.css

./5F5A58EA/overrides_custom.css

./5F5A58EA/dataDisplays.css

./5F5A58EA/samples.css

./5F5A58EA/lists.css

./5F5A58EA/theme.css

./5F5A58EA/dialogSpecific.css

./5F5A58EA/buttons.css

./5F5A58EA/containers.css

./5F5A58EA/overrides_ie7.css

./5F5A58EA/pageSpecific.css

./5F5A58EA/themeSpecific.css

 

The page source for the css is below.

Code:
<!-- General JasperServer Styles --> 
<link rel="stylesheet" href="/jasperserver/themes/reset.css" type="text/css" media="screen"> 
<!-- Theme --> 
 
<link rel="stylesheet" href="/jasperserver/_themes/5F5A58EA/theme.css" type="text/css" media="screen"/> 
<link rel="stylesheet" href="/jasperserver/_themes/5F5A58EA/pages.css" type="text/css" media="screen"/> 
<link rel="stylesheet" href="/jasperserver/_themes/5F5A58EA/containers.css" type="text/css" media="screen"/> 
<link rel="stylesheet" href="/jasperserver/_themes/5F5A58EA/buttons.css" type="text/css" media="screen"/> 
<link rel="stylesheet" href="/jasperserver/_themes/5F5A58EA/lists.css" type="text/css" media="screen"/> 
<link rel="stylesheet" href="/jasperserver/_themes/5F5A58EA/controls.css" type="text/css" media="screen"/> 
<link rel="stylesheet" href="/jasperserver/_themes/5F5A58EA/dataDisplays.css" type="text/css" media="screen"/> 
<link rel="stylesheet" href="/jasperserver/_themes/5F5A58EA/pageSpecific.css" type="text/css" media="screen"/> 
<link rel="stylesheet" href="/jasperserver/_themes/5F5A58EA/dialogSpecific.css" type="text/css" media="screen"/> 
 
<!--[if IE 7.0]>
    <link rel="stylesheet" href="/jasperserver/_themes/5F5A58EA/overrides_ie7.css" type="text/css" media="screen"/>
<![endif]--> 
 
<!--[if IE 8.0]>
    <link rel="stylesheet" href="/jasperserver/_themes/5F5A58EA/overrides_ie8.css" type="text/css" media="screen"/>
<![endif]--> 
 
<link rel="stylesheet" href="/jasperserver/_themes/5F5A58EA/overrides_custom.css" type="text/css" media="screen"/> </td></tr></tbody></table>
jgh's picture
jgh
315
Joined: Aug 27 2010 - 4:24pm
Last seen: 5 years 3 months ago
0

 Two issues after the install: default security policy, css

I had to use the default security policy from mysql in 3.5.0 to be able to start jasperserver. Is there a default security policy sql for mysql and postgresql for 4.0.0?

Also the css was all messed up. It was looking for _themes/5F5A58EA however I had themes/default. I renamed the directories, and it looks a little better, but not close to I'm sure it needs to be.

See attachment for page source and list of files under themes.

I didn't look at the example file, or I don't recall, however I did use the installation document to create/verify it.

Thanks!

jgh's picture
jgh
315
Joined: Aug 27 2010 - 4:24pm
Last seen: 5 years 3 months ago
0

 any ideas on this anyone?

jgh's picture
jgh
315
Joined: Aug 27 2010 - 4:24pm
Last seen: 5 years 3 months ago
0

 Here is a screenshot of jasperserver from source and the issues with themes/css I am seeing.

Thanks!

jgh's picture
jgh
315
Joined: Aug 27 2010 - 4:24pm
Last seen: 5 years 3 months ago
0

 Any help on this? I am unable to update the port for this reason. Thanks!

jgh's picture
jgh
315
Joined: Aug 27 2010 - 4:24pm
Last seen: 5 years 3 months ago
0

 I was able to fix this with the following patch to the build process.

jgh's picture
jgh
315
Joined: Aug 27 2010 - 4:24pm
Last seen: 5 years 3 months ago
0

I've done ask explained here, but am still seeing this error:

 

assemble-export-files-pro:

BUILD FAILED
/home/kburns/sandbox/jasperserver-4.0-src/js-builds/tags/jasperserver/buildomatic/build.xml:149: src '/home/kburns/sandbox/jasperserver-4.0-src/js-builds/tags/jasperserver/export-tool/target/js-pro-export-import-tool.zip' doesn't exist.

 

default_master.properties is:

js-path=/home/kburns/sandbox/jasperserver-4.0-src/js-builds/tags/jasperserver
js-pro-path=/home/kburns/sandbox/jasperserver-4.0-src/js-builds/tags/jasperserver
js-repo-path=/home/kburns/sandbox/jasperserver-4.0-src/js-builds/tags/jasperserver-repo
maven = /usr/share/maven2/bin/mvn
maven.home=/usr/share/maven2

 

Any ideas?

 

 



Post Edited by kburns at 03/01/2011 17:43
kburns's picture
153
Joined: Jan 13 2011 - 10:34am
Last seen: 6 years 7 months ago
0

 Seems like it's looking for a pro resource. Are you building pro or CE? Maybe you're trying to specify both a js-path and a js-pro path breaks the script? 

ernestoo's picture
7596
Joined: Nov 29 2010 - 11:59am
Last seen: 1 year 8 months ago
0

 Have you defined your:

appServerType

appServerDir

dbType

dbUsername

dbPassword

dbHost

 

?

Code:
This is my default_master.properties:
 
appServerType = tomcat5
appServerDir = /usr/local/tomcat5.5
dbType = postgresql
dbUsername = pgsql
dbPassword = pgsql
dbHost = localhost
maven = /usr/local/share/java/maven2/bin/mvn
js-path = /usr/ports/databases/jasperserver/work/jasperreports-server-cp-4.0.0-src/jasperserver
js-pro-path = /usr/ports/databases/jasperserver/work/jasperreports-server-cp-4.0.0-src/jasperserver
js-repo-path = /usr/ports/databases/jasperserver/work/jasperreports-server-cp-4.0.0-src/jasperserver-repo</td></tr></tbody></table><br><br>Post Edited by jgh at 03/01/2011 17:54
jgh's picture
jgh
315
Joined: Aug 27 2010 - 4:24pm
Last seen: 5 years 3 months ago
0

Yup, those are all set to the same values that are working with the regular 4.0 professional jasperreport server

kburns's picture
153
Joined: Jan 13 2011 - 10:34am
Last seen: 6 years 7 months ago
0

Opps, as a reply to Ernestoo, yes this is a professional 4.0 install.

If I don't have js-path or js-pro-path defined, I get this almost immediately on install-jdbc-dep

BUILD FAILED
/home/kburns/sandbox/jasperserver-4.0-src/js-builds/tags/jasperserver/buildomatic/bin/dev.xml:500: The following error occurred while executing this line:
/home/kburns/sandbox/jasperserver-4.0-src/js-builds/tags/jasperserver/buildomatic/bin/dev.xml:91: Java returned: 1


If I have both js-path and js-pro-path defined, I get the above error on assemble-export-files-pro after a minute and a half of running through the script.

BUILD FAILED
/home/kburns/sandbox/jasperserver-4.0-src/js-builds/tags/jasperserver/buildomatic/build.xml:149: src '/home/kburns/sandbox/jasperserver-4.0-src/js-builds/tags/jasperserver/export-tool/target/js-pro-export-import-tool.zip' doesn't exist.

 

kburns's picture
153
Joined: Jan 13 2011 - 10:34am
Last seen: 6 years 7 months ago
0

 you shouldn't need to define maven.home, as this is found if maven is found under your maven definition.

jgh's picture
jgh
315
Joined: Aug 27 2010 - 4:24pm
Last seen: 5 years 3 months ago
0

Ah yes, good catch. I've taken that out. As an update my default_master.properties has:

js-path=/home/kburns/jasperreports-server-4.0.0-src/jasperserver
js-pro-path=/home/kburns/jasperreports-server-4.0.0-src/jasperserver-pro
js-repo-path=/home/kburns/jasperreports-server-4.0.0-src/jasperserver-repo
maven=/usr/share/maven2/bin/mvn

And with the verbose flag I see this:

BUILD FAILED
/home/kburns/jasperreports-server-4.0.0-src/jasperserver/buildomatic/bin/dev.xml:417: The following error occurred while executing this line:
/home/kburns/jasperreports-server-4.0.0-src/jasperserver/buildomatic/bin/dev.xml:91: Java returned: 1
    at org.apache.tools.ant.taskdefs.Java.execute(Java.java:111)
    at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
    at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
    at org.apache.tools.ant.Task.perform(Task.java:348)
    at org.apache.tools.ant.taskdefs.Sequential.execute(Sequential.java:68)
    at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
    at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
    at org.apache.tools.ant.Task.perform(Task.java:348)
    at org.apache.tools.ant.taskdefs.MacroInstance.execute(MacroInstance.java:398)
    at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
    at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
    at org.apache.tools.ant.Task.perform(Task.java:348)
    at org.apache.tools.ant.taskdefs.Sequential.execute(Sequential.java:68)
    at net.sf.antcontrib.logic.IfTask.execute(IfTask.java:217)
    at sun.reflect.GeneratedMethodAccessor10.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
    at org.apache.tools.ant.TaskAdapter.execute(TaskAdapter.java:154)
    at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
    at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
    at org.apache.tools.ant.Task.perform(Task.java:348)
    at org.apache.tools.ant.Target.execute(Target.java:390)
    at org.apache.tools.ant.Target.performTasks(Target.java:411)
    at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1397)
    at org.apache.tools.ant.Project.executeTarget(Project.java:1366)
    at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
    at org.apache.tools.ant.Project.executeTargets(Project.java:1249)
    at org.apache.tools.ant.Main.runBuild(Main.java:801)
    at org.apache.tools.ant.Main.startAnt(Main.java:218)
    at org.apache.tools.ant.launch.Launcher.run(Launcher.java:280)
    at org.apache.tools.ant.launch.Launcher.main(Launcher.java:109)

Total time: 9 seconds

 

kburns's picture
153
Joined: Jan 13 2011 - 10:34am
Last seen: 6 years 7 months ago
0

 What target is this happening with? What maven sources are you using to build?

jgh's picture
jgh
315
Joined: Aug 27 2010 - 4:24pm
Last seen: 5 years 3 months ago
0

This is happening on build-pro after getting through all the setup/config/init stuff (ie install-jdbc-dep, set-pro-webapp-name, etc)

What do you mean by maven sources? My mvn looks like:

/usr/share/maven2/bin/mvn -v
Apache Maven 2.2.1 (rdebian-1)
Java version: 1.6.0_20
Java home: /usr/local/lib/jdk1.6.0_20/jre
Default locale: en_US, platform encoding: UTF-8
OS name: "linux" version: "2.6.32-27-generic" arch: "amd64" Family: "unix"

Now I am getting "Failed to resolve artifact" which helps, but I'm still not sure what the instructions mean. Where can I find these jars on the "project website"? Why would they not come included with the source?

     [java] [INFO] Failed to resolve artifact.
     [java]
     [java] Missing:
     [java] ----------
     [java] 1) jaspersoft.ji-pro:ji-license:jar:4.0.0
     [java]
     [java]   Try downloading the file manually from the project website.
     [java]
     [java]   Then, install it using the command:
     [java]       mvn install:install-file -DgroupId=jaspersoft.ji-pro -DartifactId=ji-license -Dversion=4.0.0 -Dpackaging=jar -Dfile=/path/to/file
     [java]
     [java]   Alternatively, if you host your own repository you can deploy the file there:
     [java]       mvn deploy:deploy-file -DgroupId=jaspersoft.ji-pro -DartifactId=ji-license -Dversion=4.0.0 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]
     [java]
     [java]   Path to dependency:
     [java]       1) jaspersoft.ji-pro:ji-common:jar:4.0.0
     [java]       2) jaspersoft.ji-pro:ji-license:jar:4.0.0
     [java]
     [java] ----------
     [java] 1 required artifact is missing.
     [java]
     [java] for artifact:
     [java]   jaspersoft.ji-pro:ji-common:jar:4.0.0
     [java]
     [java] from the specified remote repositories:
     [java]   JasperForge Maven Repository (http://jasperforge.org/svn/repos/maven2),
     [java]   central (http://repo1.maven.org/maven2),
     [java]   Maven Snapshots (http://snapshots.maven.codehaus.org/maven2),
     [java]   JBoss (http://repository.jboss.org/maven2),
     [java]   js-repo-svn (file://${repo-path}),
     [java]   Repo1 Maven (http://repo1.maven.org/maven2/)
     [java]
     [java]
     [java]
     [java] [INFO] ------------------------------------------------------------------------
     [java] [INFO] For more information, run Maven with the -e switch
     [java] [INFO] ------------------------------------------------------------------------
     [java] [INFO] Total time: 4 seconds
     [java] [INFO] Finished at: Wed Mar 02 12:57:13 EST 2011
     [java] [INFO] Final Memory: 43M/238M
     [java] [INFO] ------------------------------------------------------------------------

 

I am using the 4.0 professional source, but the strangest thing is that when I run js-ant build-ce, it compiles successfully.

kburns's picture
153
Joined: Jan 13 2011 - 10:34am
Last seen: 6 years 7 months ago
0

kburns
Wrote:

This is happening on build-pro after getting through all the setup/config/init stuff (ie install-jdbc-dep, set-pro-webapp-name, etc)

What do you mean by maven sources? My mvn looks like:

/usr/share/maven2/bin/mvn -v
Apache Maven 2.2.1 (rdebian-1)
Java version: 1.6.0_20
Java home: /usr/local/lib/jdk1.6.0_20/jre
Default locale: en_US, platform encoding: UTF-8
OS name: "linux" version: "2.6.32-27-generic" arch: "amd64" Family: "unix"

Now I am getting "Failed to resolve artifact" which helps, but I'm still not sure what the instructions mean. Where can I find these jars on the "project website"? Why would they not come included with the source?

     [java] [INFO] Failed to resolve artifact.
     [java]
     [java] Missing:
     [java] ----------
     [java] 1) jaspersoft.ji-pro:ji-license:jar:4.0.0
     [java]
     [java]   Try downloading the file manually from the project website.
     [java]
     [java]   Then, install it using the command:
     [java]       mvn install:install-file -DgroupId=jaspersoft.ji-pro -DartifactId=ji-license -Dversion=4.0.0 -Dpackaging=jar -Dfile=/path/to/file
     [java]
     [java]   Alternatively, if you host your own repository you can deploy the file there:
     [java]       mvn deploy:deploy-file -DgroupId=jaspersoft.ji-pro -DartifactId=ji-license -Dversion=4.0.0 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]
     [java]
     [java]   Path to dependency:
     [java]       1) jaspersoft.ji-pro:ji-common:jar:4.0.0
     [java]       2) jaspersoft.ji-pro:ji-license:jar:4.0.0
     [java]
     [java] ----------
     [java] 1 required artifact is missing.
     [java]
     [java] for artifact:
     [java]   jaspersoft.ji-pro:ji-common:jar:4.0.0
     [java]
     [java] from the specified remote repositories:
     [java]   JasperForge Maven Repository (http://jasperforge.org/svn/repos/maven2),
     [java]   central (http://repo1.maven.org/maven2),
     [java]   Maven Snapshots (http://snapshots.maven.codehaus.org/maven2),
     [java]   JBoss (http://repository.jboss.org/maven2),
     [java]   js-repo-svn (file://${repo-path}),
     [java]   Repo1 Maven (http://repo1.maven.org/maven2/)
     [java]
     [java]
     [java]
     [java] [INFO] ------------------------------------------------------------------------
     [java] [INFO] For more information, run Maven with the -e switch
     [java] [INFO] ------------------------------------------------------------------------
     [java] [INFO] Total time: 4 seconds
     [java] [INFO] Finished at: Wed Mar 02 12:57:13 EST 2011
     [java] [INFO] Final Memory: 43M/238M
     [java] [INFO] ------------------------------------------------------------------------

 

I am using the 4.0 professional source, but the strangest thing is that when I run js-ant build-ce, it compiles successfully.

 

What I mean by the maven sources is the actual repository sources. As part of my porting Jasperserver to FreeBSD, I pressed an issue that nothing should be downloaded during the build, and everything that is required to build JasperServer should be available to download and be built against those sources. And to this request, the developers as part of the release cycle now, as far as I know, plan on distributing the maven repository as part of the release, so you can build against it.

This is the maven repository file for 4.0.0: http://sourceforge.net/projects/jasperserver/files/JasperServer/JasperSe...

If you move aside your current .2 directory, and unzip this into the contents of a new .m2 directory, it should build. I can only really attest to building jasperserver, though, as I have not built jasperserver-pro, at this time.

jgh's picture
jgh
315
Joined: Aug 27 2010 - 4:24pm
Last seen: 5 years 3 months ago
0

Turns out everything was fixed by adding repo-path to default_master.properties.
Any ideas why there was no reference anywhere to this setting in the documentation?

Anywho. I've now run into another problem, but I think I've hijacked this thread enough. Will start another.

(Thanks so much for all your help!)

kburns's picture
153
Joined: Jan 13 2011 - 10:34am
Last seen: 6 years 7 months ago
0

kburns
Wrote:

Turns out everything was fixed by adding repo-path to default_master.properties.
Any ideas why there was no reference anywhere to this setting in the documentation?

Anywho. I've now run into another problem, but I think I've hijacked this thread enough. Will start another.

(Thanks so much for all your help!)

 

That makes sense, as I had that in my configuration file posted on page2. Glad you have it building now. I'd suggest building off of the zip file, as I've seen the maven repo get corrupted, and because of that would not compile jasperserver. Using the distributed zip ensures a successful build everytime.

Glad we could help!

jgh's picture
jgh
315
Joined: Aug 27 2010 - 4:24pm
Last seen: 5 years 3 months ago
0

I just wrote a bug in the "js-repo-path" vs "repo-path" issue.

This is a bug in the Source Build Guide. Very sorry for the trouble it has caused. The property name should be: repo-path

The buildomatic/sample_conf/source/<dbType>_master.properties files are actually correct.

Inside you will see "repo-path"

I will fix and repost the Source Build Guide (but it might take a week or so due to other deadlines).

tkavanagh's picture
2773
Joined: Jul 7 2006 - 8:54am
Last seen: 4 years 9 months ago
0

 Thanks. I'll be sure to fix this in the port in the upcoming releases.

jgh's picture
jgh
315
Joined: Aug 27 2010 - 4:24pm
Last seen: 5 years 3 months ago
0
Oddly, I am using js-repo-path in the port, and it is working just fine. Is there any reason that it is working this way? Look at the pre-build target.
http://www.freebsd.org/cgi/cvsweb.cgi/ports/databases/jasperserver/Makefile?rev=1.2;content-type=text/x-cvsweb-markup
jgh's picture
jgh
315
Joined: Aug 27 2010 - 4:24pm
Last seen: 5 years 3 months ago
Feedback
randomness