install iReport on ubuntu

1

Hello -

 

So - I am looking to install the latest ireports onto a ubuntu 64bit 10.04 LTS server.

 

Totally missing the walkthrough install instructions, if they are somewhere at all.

     If you can point me to those that would be perfect.

If there isn't a good resource my real question comes to:

1. ) Download the iReport-3.7.6.tar.gz file download --Done ( just in temporary location )

2. ) tar -xvzf iReport-3.6.7.tar.gz -- Done ( same folder )

3. ) moved file to : /opt/iReport-3.6.7 -- Done

------------------------------------------------------------

No problems yet ... right ?

Next before I installed or compiled the source code I went ahead and tried to get the correct JDK

4. ) Install Open JDK Development Kit (openjdk-6-jdk)

4.b ) Install Standard Java Development Kit (default-jdk)

------------------------------------------------------------------

No problems yet ... right ?

Any special steps to install the JDKs ??

It seemed from the little i was able to find that i needed to go to <ireport dir>/bin/startup.sh - but that isn't in the un tarred file -- as far as I can tell.

 

I am lost what my steps should be or what to do next.

 

Any help would be appreciated.

 

Thanks in advance!

Jeremy

PS - let me know if there is anything I need/should provide, as this is my first time posting :)

 



Post Edited by iamhers at 12/29/2010 23:01
iamhers's picture
Joined: Dec 27 2010 - 11:56am
Last seen: 8 years 4 months ago

3 Answers:

-1

I'm starting <installation_dir>/iReport-3.7.x/bin/ireport on my Ubuntu-64 machine, runs without problems



Post Edited by lairdchris at 01/03/2011 14:47
lairdchris's picture
Joined: Feb 9 2010 - 4:57am
Last seen: 1 month 3 weeks ago
0

 Hi, trying to install iReport-4.0.2. on Ubuntu 10.10...

The install script seems to be /opt/iReport-4.0.2/ireport

I get the following error:

cat: ./../etc/ireport.sh.clusters: No such file or directory

Your user directory (/opt/iReport-4.0.2/bin) cannot reside inside your NetBeans installation directory (/opt/iReport-4.0.2).

--------------------------------------------------------------------------------------------------------------------------------------------------------------------
The readme.txt mentions:
'This is the first release of iReport for NetBeans 6.0.
iReport for NetBeans is available as standalone application based on the NetBeans RCP and as plugin for NetBeans IDE.'
 
Is there a dependency on Netbeans?
 
Thanks
Yogan

 

ynaidoo's picture
Joined: Jul 22 2011 - 6:44am
Last seen: 1 month 2 weeks ago
0

 Ok, sounds like I downloaded the netbeans dependent version.

I downloaded the latest version from here: http://sourceforge.net/projects/ireport/files/iReport/iReport-4.0.2/

and it worked fine.

 

Ciao

Yogan

ynaidoo's picture
Joined: Jul 22 2011 - 6:44am
Last seen: 1 month 2 weeks ago
Feedback
randomness