Probelm with olap report in js 2.0

I've updated js 1.2.1 to 2.0 using the war distribution and the given sql scripts.
that works fine.
At first I've tried to run a report built on a jdbc connection. That works fine, the report is generated in the way it should be.

After that i tried to run a report built on a mondrian connection. But the only thing that was generated was a blank page. Now controll icons and now report.
After that I've tried to generate the report using the backgroung excecution. Here the following message is shown:
Job: Background Execution (ID: 1)
Report unit: /Kostenanalyse_pro_Monat
Quartz Job: ReportJobs.job_1
Quartz Trigger: ReportJobs.trigger_1_0
java.lang.NoSuchMethodError: mondrian.olap.Query.getMdxHierarchiesOnAxis(I)[Lmondrian/olap/Hierarchy;
at net.sf.jasperreports.olap.mondrian.JRMondrianResult.<init>(
at net.sf.jasperreports.olap.JRMondrianDataSource.<init>(
at net.sf.jasperreports.olap.JRMondrianQueryExecuter.createDatasource(
at net.sf.jasperreports.engine.fill.JRFillDataset.createQueryDatasource(
at net.sf.jasperreports.engine.fill.JRFillDataset.initDatasource(
at net.sf.jasperreports.engine.fill.JRBaseFiller.setParameters(
at net.sf.jasperreports.engine.fill.JRBaseFiller.fill(
at net.sf.jasperreports.engine.fill.JRFiller.fillReport(
at net.sf.jasperreports.engine.JasperFillManager.fillReport(
at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.EngineServiceImpl.fillReport(
at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.EngineServiceImpl.fillReport(
at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.EngineServiceImpl.executeReport(
at com.jaspersoft.jasperserver.api.engine.jasperreports.domain.impl.ReportUnitRequest.execute(
at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.EngineServiceImpl.execute(
at com.jaspersoft.jasperserver.api.engine.scheduling.quartz.ReportExecutionJob.executeReport(
at com.jaspersoft.jasperserver.api.engine.scheduling.quartz.ReportExecutionJob.executeAndSendReport(
at com.jaspersoft.jasperserver.api.engine.scheduling.quartz.ReportExecutionJob.execute(
at org.quartz.simpl.SimpleThreadPool$

I must also say that my analysis views are working well. So mondrian is running.
It seems like there is a problem in the communication between jasperreports and mondrian.

Has anybody a guess what problem this could be?

Maybe Sherman has a idea?

greetz jens
jens_noering's picture
Joined: Feb 20 2007 - 11:54pm
Last seen: 8 years 2 months ago

2 Answers:

In JS 2.0, Mondrian has been upgraded to 2.3.2. This Mondrian release is not backward compatible to previous ones at the API level, and because of this the JasperReports Mondrian query executer would not work with it.

After the JS 2.0 release, the JR Mondrian query executer code has been updated to be compatible with Mondrian 2.3.2 (note this implies that older Mondrian versions are no longer supported). If you intend to use Mondrian reports in JS 2.0, you'll have to use a JR post 1.3.4 snapshot. You can build yourself one by getting the code from SVN trunk, or you can download one (corresponding to SVN rev. 1787) from [url= JasperSoft Maven repository.

lucianc's picture
Joined: Jul 17 2006 - 1:10am
Last seen: 21 hours 42 min ago
Thanxx for your help,

after downloading the new 1.3.5 snapshot it works.

Have a nice weekend,

greetz jens
jens_noering's picture
Joined: Feb 20 2007 - 11:54pm
Last seen: 8 years 2 months ago