JasperServer Source Build Error


I am trying to build the source for jasperserver according to source build guide
with maven2 and got the following error when try :

cd jasperserver/trunk
mvn clean install in windows command prompt.

1 required artifact is missing.

for artifact: com.jaspersoft.jasperserver:jasperserver-ws-war-0.9.2.war

[INFO] [clean:clean]
[INFO] Deleting directory F:\rubel-resources\jasperserver\jasperserver\trun
[INFO] Deleting directory F:\rubel-resources\jasperserver\jasperserver\trun
[INFO] Deleting directory F:\rubel-resources\jasperserver\jasperserver\trun
[INFO] [resources:resources]
[INFO] Using default encoding to copy filtered resources.
[INFO] --------------------------------------------------------------------
[INFO] --------------------------------------------------------------------
[INFO] Failed to resolve artifact.

No versions are present in the repository for the artifact with a range [1.

from the specified remote repositories:
Maven Snapshots (http://snapshots.maven.codehaus.org/maven2/),
central (http://repo1.maven.org/maven2),
ApacheSVN-central (http://svn.apache.org/maven-snapshot-repository),
jasperServer (file:/F:/rubel-resources/jasperserver/jasperserver-repo/tru

The Source Build Guide "Unresolved artifact – corrupt artifact:" Section advise to remove lowagie directory.
After deleting when trying to >"mvn clean install" it again gives the same error.

And Eclipse Editor when building workspace gives following error :

No versions are present in the repository for the artifact with a range [1.02b,) com.lowagie:itext-null.jar

10/17/06 12:26:20 PM BDT: Missing:
1) com.jaspersoft.jasperserver.api.engine.impl:jasperserver-api-engine-impl:jar:0.9.2

Try downloading the file manually from the project website.

Then, install it using the command:
mvn install:install-file -DgroupId=com.jaspersoft.jasperserver.api.engine.impl -DartifactId=jasperserver-api-engine-impl \
-Dversion=0.9.2 -Dpackaging=jar -Dfile=/path/to/file

Path to dependency:
1) com.jaspersoft.jasperserver:jasperserver-ws-war:war:0.9.2
2) com.jaspersoft.jasperserver.api.engine.impl:jasperserver-api-engine-impl:jar:0.9.2

Any Help Appriciated

alauddinctgbd's picture
Joined: Aug 4 2006 - 8:37pm
Last seen: 17 years 1 month ago

1 Answer:


These artifact resolution problems can be tricky, given that you have tried removing the lowagie directory (from HOME/.m2/repository tree), it looks like it would be best to install the lowagie jar by hand.

You can do this two ways. One is how maven2 suggests in the error message (ie maven-install:install-file etc).

Or you can go to your .m2/repository directory and create the directory structure by hand, and put the lowagie jar and the lowagie pom file into the final directory.

The jar can be downloaded by going to one of the remote repositories lists in the error message and navigating to the location for the lowagie jar.

tkavanagh's picture
Joined: Jul 7 2006 - 8:54am
Last seen: 9 years 2 weeks ago