Where is BitRock Installer?

I downloaded jasperintelligence-1.1.0 for Windows platform. I also found a JasperIntelligence-Install-Guilde.pdf, dated 7/19/2006. In this document it states that to install the product, I need to use BitRock Installer. Do I need to download BitRock Installer from bitrock.com? I was expecting to see an EXE or MSI file that packs JasperIntelligence. Am I looking at two incompatible download / document?

ChristFollower's picture
Joined: Sep 19 2006 - 9:33am
Last seen: 17 years 6 days ago

6 Answers:

We should be getting the installer out in the next week.

swood's picture
Joined: Jun 21 2006 - 12:48pm
Last seen: 10 years 11 months ago
I'm waiting anxiously for the installer. I was able to install version 1.1.0 from the current distribution. Look for my post on the subject.
javydreamercsw's picture
Joined: Jul 17 2006 - 9:46pm
Last seen: 6 years 11 months ago
How do I find your post on the installation? I found another document discussing the installation from the WAR. I was able to install and create the database. But when I tried to import the sample data (stated on page 3) using the command:

ji-import.bat --import-path=ji-catalog --import-file=ji-catalog.xml --verbase

It failed with a hibernate exception. I don't think I have hibernate (unless the WAR comes with hibernate) installed. Is hibernate required for the sample to work?

Thanks again.
ChristFollower's picture
Joined: Sep 19 2006 - 9:33am
Last seen: 17 years 6 days ago
Here's the link:

I haven't tried the examples, just made sure my previous reports works with the new version. The only thing I'm missing is the iReport plugin that isn't working properly. I'm waiting for the installer that must be released this week accourding to Jasper employees...
javydreamercsw's picture
Joined: Jul 17 2006 - 9:46pm
Last seen: 6 years 11 months ago
regarding running the ji-import.bat: all jars/classes needed to run the import are included with jasperintelligence (in jasperserver/WEB-INF/lib).

So, if you are not getting the hibernate jar then the above lib dir is probably not on your path when executing ji-import.bat. You can take a look at the bat file, and make sure it is pointing to where you lib dir is.

Also, keep in mind that you can run the server without loading the sample data (which the ji-import.bat does).

There are scripts in the scripts directory jasperserverCreate.ddl etc. that will set up the MySQL database for you that jasperintelligence needs.

Please refer again to the jasperintelligence-warfile-install-guide.pdf. It describes the database setup steps.

tkavanagh's picture
Joined: Jul 7 2006 - 8:54am
Last seen: 9 years 2 weeks ago
In our case jasper is deployed as it should, but we can't log in. We have two users in the meta table: anynomousUser and jasperadmin, both are enabled (the bits in the bitfield are set to 1) but whenever we try to log in we get the following message:

WARN LoggerListener,http-8080-Processor25:55 - Authentication event AuthenticationFailureLockedEvent: jasperadmin; details: org.acegisecurity.ui.WebAuthenticationDetails@fffe3f86: RemoteIpAddress:; SessionId: 94948973BE3FF57B7061D4D2E5CE4DDD; exception: User account is locked

Any thoughts how to fix this?
albundy's picture
Joined: Oct 15 2006 - 11:51pm
Last seen: 16 years 11 months ago