Login problem: New install with existing mysq

By: David Sachdev - dsachdev
Login problem: New install with existing mysq
2006-06-21 14:05
I installed JasperServer using my existing mySQL
database and allowed JasperServer to install its own
copy of Tomcat onto a Ubunto machine:

root@dsachdev-laptop:/etc/init.d# uname -a
Linux dsachdev-laptop 2.6.15-25-386 #1 PREEMPT Wed Jun
14 11:25:49 UTC 2006 i686 GNU/Linux

I supplied it with the root password for the existing
mySQL database and it did in fact create the
JasperServer tables. I launched the application, and
tried to log in with jasperadmin and the password that
I supplied, but kept getting the following error:

Invalid credentials supplied.
Could not login to JasperServer.

I checked the User table in the database, and saw that
the password I was using was in fact correct, and that
the user was enabled.

I did update the password in the database, and tried
the new password with no success.

I went through the install guide and also tried out the
other users that it mentions there (plus what I saw
enabled in the database) and each time I got the
"invalid credentials" message.

The log file only has the following message:

16:59:33,493 WARN
LoggerListener,http-8080-Processor23:60 -
Authentication event
AuthenticationFailureBadCredentialsEvent: jasperadmin;
RemoteIpAddress:; SessionId:
107F69C0251666012A8BBCBE6B72E5E1; exception: Bad

By: T Kavanagh - tkavanagh
RE: Login problem: New install with existing
2006-06-27 07:37
David, I'm working on creating the installation routines right now for the 1.0 release. I will make sure that the test sequences of using an existing MySQL and and "bundled" (ie installer installed) tomcat. That should be out late today or tomorrow.

I will look for any misconfigurations like you are seeing...

ktrinad's picture
Joined: Aug 9 2006 - 2:36am
Last seen: 17 years 1 month ago

0 Answers:

No answers yet