jasper intelligence login problem

loaded for existing tomcat mysql using the installer version 1.0.1 for Linux. I am using suse linux.

App starts fine in tomcat, but when I try to login using the password I setup in the installer for jasperadmin I get a failed login credential. I checked the datasource file and mysql JSUser table and the password is the same as what I typed in.

Now the account seems locked from the error I get from the Tomcat log. Listing at end of e-mail.

How do I unlock the user?
What else can I do to troubleshoot?

Tomcat output
INFO: Find registry server-registry.xml at classpath resource
Sep 1, 2006 1:43:19 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 17559 ms
13:43:59,507 WARN LoggerListener,http-8080-Processor24:55 - Authentication event AuthenticationFailureLockedEvent: jasperadmin; details: org.acegisecurity.ui.WebAuthenticationDetails@fffd148a: RemoteIpAddress:; SessionId: 230F1DB5563F6A1998428045ECA8C87E; exception: User account is locked
13:43:59,515 WARN JSCommonController,http-8080-Processor24:85 - There was a login error
vijitc's picture
Joined: Sep 1 2006 - 1:55am
Last seen: 5 years 6 months ago

1 Answer:

OK I solved my own problem. Might as well post the answer.

Since I ran the installer against an existing Tomcat installation, I had to manualy copy over the JDBC driver for mysql to the $CATALINA_HOME/common/lib directory. THe problem was that I took an old version that I had on my workstation called:


I downloaded the newer version:


rstarted Tomcat and no more weired lock errors and I got into the application just fine.
vijitc's picture
Joined: Sep 1 2006 - 1:55am
Last seen: 5 years 6 months ago