error using JasperReport with Sun Studio Crea

0
By: ignacioal - ignacioal
error using JasperReport with Sun Studio Crea
2006-06-08 18:28
Hi,

I am a newbie using JasperReports v1.2.0 in a J2SE environment using Sun AS 8.

The .jasper file is created correctly and my .jrxml file displays fine in iReport-1.2.0

I need to create reports in Studio creator the Sun.

I tried many examples but I always end up with the same error msg and can't find a solution for it.

This is the error message:


net.sf.jasperreports.engine.JRException: Error loading expression class : testreport_1142608681187_139038


InputStream wfile = new FileInputStream(new File("c:/Program file/JasperSoft/iReport-1.2.2/reports/report.jrxml"));
JasperDesign design = JRXmlLoader.load(wfile);
JasperReport report = JasperCompileManager.compileReport(design);

JasperPrint print = JasperFillManager.fillReport(report,param, conn);


I have tried to change the java.policy of the JRE adding:

permission java.lang.RuntimePermission "createClassLoader";
in this file:
C:\Sun\Creator\SunAppServer8\domains\creator\config\server.policy (windows)
I put it in between grant { };

but even this doesn't work.


Has anyone had the same problem and maybe found a solution for it?
I would be very thankful if someone could point me in the right direction.
2006 IR Open Dicussion's picture
Joined: Aug 10 2006 - 3:24am
Last seen: 13 years 3 months ago

0 Answers:

No answers yet
Feedback
randomness