JasperManager.loadXmlDesign() never returns

By: Zihong Lu - zihong
JasperManager.loadXmlDesign() never returns
2003-12-09 22:53
I was tracing a problem in iReport (https://sourceforge.net/forum/forum.php?thread_id=984918&forum_id=217623), and found this problem on JasperReports side. Hope people know how can help me.

I tried to put iReport into a jar file, with the proper manifest, and put the iReport.jar in the same directory as the jasperreports-0.5.0.jar and other required jar files. With the same compiled iReport class code, before jarred, the iReport worked fine. After jarred, the iReport could still start, could create new docs, open existing docs, but could not compile xml templates. It turned out that the function


in iReport's IReportCompiler.java never returned. I had replaced the call with the following calls:

JasperDesign jasperDesign =
JRBshCompiler theCompiler = new JRBshCompiler();
JasperReport result =

and found out that the loadXmlDesign() never returned (The inputStream is not null, I checked it). Again, before jarred, the iReport was working fine.

Any idea what went wrong? Any suggestion is highly appreciated. Here is another link that I found on related issue, but it did not work for me:



By: Zihong Lu - zihong
RE: JasperManager.loadXmlDesign() never returns
2003-12-10 10:38
It turned out that the Classpath in my manifest mispelled the commons-digester.jar to commons-digest.jar. It would be nice if the system throws an exception when it did not find the commons-digest.jar package, or any necessary package in that regard.

Anyway, after corrected it, this problem solved, even though the iReport.jar still does not work. iReport.jar complained about


This is a different issue.
2002 JI Open Discussion's picture
Joined: Aug 10 2006 - 3:28am
Last seen: 16 years 7 months ago

0 Answers:

No answers yet