javax.print

By: Chuck Deal - cdeal
javax.print
2002-11-04 14:31
The Home Page for this project states that JDK 1.2.2 or higher is required. Yet, I notice that the javax.print packages are being used. These packages are included in JDK 1.4. Is there an optional jar that contains these packages. Or does this mean that JasperReports requires JDK 1.4.0 or higher?




By: Teodor Danciu - teodord
RE: javax.print
2002-11-05 12:58

Hi,

Only ONE class in the whole library needs JDK 1.4
functionality:

dori.jasper.engine.export.JRPrintServiceExporter

If in your application you don't use this class,
which makes use of the Java Print Service API,
you never get into any trouble, even if you have JDK1.2.2 installed on your system.

However, if you will compile yourself the library source files, and you don't have JDK1.4, simply remove this class from the tree.
As you can see, the build.xml file found in the root directory of the project, checks to see what version
of JDK you are using and includes or excludes this
Java file from the compilation process.

I suggest you use ANT to compile the project.
The core library still supports JDK1.2.2.
The class mentioned should be seen as optional.

Thank you,
Teodor
2006 IR Open Dicussion's picture
Joined: Aug 10 2006 - 3:24am
Last seen: 16 years 9 months ago

0 Answers:

No answers yet
Feedback
randomness