installation 8.2 openJDK

hi 

I try to install last version 8.2.0 jasper server but the installation on window fail, I install java JDK  11  and Installation finished successfully

I try to install openjdk instead JDK 11  but I have same error 

It is mandatory install oracle JDK 11  ?

thanks 

erika

erika.chinchio's picture
Joined: Feb 25 2021 - 2:06am
Last seen: 1 week 1 day ago

Thank you for posting to the Jaspersoft Community. Our team of experts has read your question and we are working to get you an answer as quickly as we can. If you have a Jaspersoft Professional Subscription plan, please visit https://support.tibco.com/s/ for direct access to our technical support teams offering guaranteed response times.

arai_4 - 3 months 3 weeks ago

4 Answers:

Hello,

Could you please share the error you received while Jasperserver installation?

For the Windows operating system, you can use the Oracle JDK v8 (minimum required version 1.8.0_163), 11, 17.

Or you can also use Eclipse Adoptium (formerly AdoptOpenJDK) Oracle OpenJDK 11 ● Eclipse OpenJ9 ● HotSpot ● Corretto

For more information, please go through the below-attached document and refer section"Java Virtual Machines (JVM)":

https://docs.tibco.com/pub/js-jrs/8.2.0/doc/pdf/js-jrs_8.2.0_Platform-Su...

I hope this will help you, thanks!

Swapnil Pawar's picture
Joined: Apr 22 2021 - 5:44am
Last seen: 12 hours 14 min ago

Hi

with AdoptOpenJDK works,  Installation finished successfull

thks erika

 

erika.chinchio's picture
Joined: Feb 25 2021 - 2:06am
Last seen: 1 week 1 day ago

hi

thank you I finally understand my errors

if I  install openjdk-20.0.1 I have a warning (see as attached image)

if I install openjdk--11.0.19  all works fine

thks erika

Attachments: 
AttachmentSize
Image icon warning.jpg157.37 KB
erika.chinchio's picture
Joined: Feb 25 2021 - 2:06am
Last seen: 1 week 1 day ago

I ran into the exact same warning when installing Jasper Server 8.2.0 on a fresh PC with JAVA_HOME set to Oracle JDK 17.0.7 (latest version).

In an attempt to get around this I uninstalled JS then tried downgrading to JS 8.1.1 still with JAVA_HOME set to Oracle JDK 17.0.7 (latest version).  This time it installed successfully without any warnings.  Problem is I want to to use JS 8.2.0 and JDK 17.  So I uninstalled both.

Finally I installed JS 8.2.0 but this time set JAVA_HOME to Oracle JDK 11.0.18 (latest version).  It installed without issue.  I then stop services uninstalled JDK 11 then reinstalled JDK 17 and set my JAVA_HOME to it.  After that rebooted.

Now I have JS 8.2.0 and JDK 17.  I'll now be able to evaluate it for work.

My question is why is there a warning when JDK 17 is supported?  Another strange thing I saw in that warning was it trying to use git.  I'm not on a development machine so I don't have it installed. 

 

jgust's picture
6522
Joined: Jun 10 2010 - 6:39am
Last seen: 1 day 15 hours ago
Feedback