Issues after changing from Postgres to MSSQL


i'm trying to install the jasperreports server pro version 7.9.0 on fedora.
We are currently running it on a windows server and want to migrate to linux.

I installed the server via the install tool, after copying the config files from out currently running server,
I get a few SQL exceptions and I dont know what to do anymore.

I've tried fixing it on my own, withour much success.

2023-04-13T06:45:04,610 ERROR SqlExceptionHelper,localhost-startStop-1:131 - [TibcoSoftware][SQLServer JDBC Driver][SQLServer]An expression of non-boolean type specified in a context where a condition is expected, near 'ilike'.
2023-04-13T06:45:04,685 ERROR SqlExceptionHelper,localhost-startStop-1:131 - [TibcoSoftware][SQLServer JDBC Driver][SQLServer]Statement(s) could not be prepared.
2023-04-13T06:45:05,045 ERROR ContextLoader,localhost-startStop-1:313 - Context initialization failed org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'proOnStartPropagator' defined in ServletContext resource [/WEB-INF/applicationContext-onStart-web-pro.xml]: Invocation of init method failed; nested exception is org.springframework.orm.hibernate5.HibernateJdbcException: JDBC exception on Hibernate data access: SQLException for SQL [n/a]; SQL state [HY000]; error code [4145]; could not extract ResultSet; nested exception is org.hibernate.exception.GenericJDBCException: could not extract ResultSet

Full error messages included as attachment

I would be very thankful for any hints on how to fix this, im on this for a while already.

nyasaki's picture
Joined: Apr 12 2023 - 10:21pm
Last seen: 5 months 6 days ago

Thank you for posting to the Jaspersoft Community. Our team of experts has read your question and we are working to get you an answer as quickly as we can. If you have a Jaspersoft Professional Subscription plan, please visit for direct access to our technical support teams offering guaranteed response times.

arai_4 - 5 months 1 week ago

At what point are you encountering the errors?  When installing or when starting the server? The errors you are seeing - do they appear in which log file?

sanderse - 5 months 1 week ago

Installation worked fine with the installer, and it did run after installing.
But then I tried switching from Postgres to MSSQL and things started breaking apart

~/jasperreports-server-7.9.0/apache-tomcat/webapps/jasperserver-pro/WEB-INF/logs/jasperserver.log is the log file

The errors occur when starting the service / server

nyasaki - 5 months 1 week ago

2 Answers:

Did you re-install the repository database or just the server?

The "ilike" statement is postgres and would not work well with MySQL.  This would happen if somehow the server thinks it is using postgres still.

To move from Postgres to MySQL, I would recommend exporting the repository, do a clean from-scratch build using MySQL, and importing the repository.

Since you are using a commercial product, have you reached out to Jaspersoft Production Support on this?

sanderse's picture
Joined: Jul 31 2017 - 3:51pm
Last seen: 1 day 15 hours ago

I cant find the link anymore, I remember changing a context file in the tomcat folder.
And since we got the software via a 3rd party, we are not able to get commercial support.

Is there any guide I can follow for the clean build?

nyasaki's picture
Joined: Apr 12 2023 - 10:21pm
Last seen: 5 months 6 days ago