Compatibility issue with RHEL 8.7

Hi Team,

We have installed jasper community server edition 8.0.0 which is compatible with Open JDK 11.
Earlier we had installed this edition on Linux server but now we are getting error "SU - module is unknown "

On comparing with our previous versions we found that there is compatibility issue with RHEL (Red hat ) version 8.7

Can the team assist us if the community edition 8.0.0 is compatible with Linux red hat version 8.7? As per the jasper community guidelines the red hat version supported for jasper is 8.2.

Is this issue occurring due to upgradation of Linux red hat versions?

Please assist asap.

heenasabnani1's picture
Joined: Dec 18 2019 - 5:08am
Last seen: 1 week 5 days ago

Hi heenasabnani1,  we got exactly the same issue after upgrading from RedHat 7 to 8.7.

We are also looking for the solution and Google brings me here. 

How is your situation now?  It seemed that there is problem to start postgresql.

psb_action_support - 2 weeks 3 days ago

Hi yes
We have sorted this issue as of now
once you start .ctlscript.sh only tomcat gets started and for postgress you will get "su - module unknown"
What you can do is using su permissions start postgres
su - postgres
after that you can start postgress and for stopping you can repeat same step
su - postgres
stop postgres

There is a file in postgres where you can find start stop commands also.

Try this and let me know if it works for you

heenasabnani1 - 1 week 5 days ago

Inside <INSTALL_PATH>/postgresql/scripts/ctl.sh you can find start stop command of postgres
so make sure you su the postgres user and run start stop command manually

heenasabnani1 - 1 week 5 days ago

2 Answers:

If the version it is not listed in the Platform Support Guide then it means it has not been certified for that version. Whether the error is because of the of the incompatibility between the JasperReports Server and the version of Red Hat is another matter. It does look like an OS error and it might be worthy to google the error for situations where such errors can occur.  

vchiem's picture
35597
Joined: May 1 2017 - 5:33pm
Last seen: 12 hours 38 min ago

There is no answer for this on Google we tried searching and hoping for lot of answers but no luck, hence we tried to raise a question on Jasper Community Support.

heenasabnani1's picture
Joined: Dec 18 2019 - 5:08am
Last seen: 1 week 5 days ago
Feedback
randomness