Resource Not Found while reportExecution via Visualize.js

We are trying to access the JasperSoft reports using Visualize.js api`s and are able to successfully fetch the InputControls , Sample Dashboards,  but getting resource not found exception only on report execution method . Do we need any permissionMask for report execution or there are some restrictions over execution . 

Resource : /organizations/organization_1/reports/Dsh_Outbound_Online_Hourly_Avg_Talktime

Also tried with Sample reports and response is still resource not found . 
Resource : /public/Samples/Reports/01._Geographic_Results_by_Segment_Report
Exception : Response : 

  1. {message: "Resource 8bc23408-f2af-4374-9345-d52eb7e13abe not found.", errorCode: "resource.not.found",…}
    1. errorCode: "resource.not.found"
    2. message: "Resource 8bc23408-f2af-4374-9345-d52eb7e13abe not found."
    3. parameters: ["8bc23408-f2af-4374-9345-d52eb7e13abe"]
      1. 0: "8bc23408-f2af-4374-9345-d52eb7e13abe"

        Implementation : 



        auth: {

        token: ********,

        preAuth: true,

        tokenName: "pp",


        function (v) {


        resource: "/public/Samples/Reports/01._Geographic_Results_by_Segment_Report",

        error: function(e) {




sharma40ashutosh's picture
Joined: May 31 2022 - 11:43pm
Last seen: 11 months 4 weeks ago

1 Answer:

Things to check:

1. The first resource path refers to an Organization and I don't see Organization specified in your visualize.js call. 

2. If you log in using the same user(pp) on Jaspersoft and run the same report do you see the same error? It could very well be permissions on the resources for that user.

JRS-SE's picture
Joined: Oct 30 2017 - 12:56pm
Last seen: 5 days 25 min ago