Jasper report : invalid path for subreports and resources

Jaspersoft Community 'Read-Only' as of July 8, 2022

Transition to New TIBCO Community Just Weeks Away

You can still search, review wiki content, and review discussions in read-only mode. Please email community@tibco.com with questions or issues requiring TIBCO review or response.

I have 2 jasperserver, I exported the report from the first one and imported them on the second one. But when i tried to edit my report using rest service, I have 400 BAD REQUEST because all my subreport path where replaced by repo:subreportName.jrxml.

In my 2 servers I have the same folder hierarchy :

root

  • organisation
    • project
      • report folder 1
        • report 1
        • sub report 1
        • sub report 2
      • report folder 2 ...

I tried to overwrite the subreports path to have something more global but all my tentative didn't worked. Here a list of all my tentative

/root/Organisation/Project/Reports/Reports-family/report-folder/sub_report_1.jrxml
/root/Organisation/Project/Reports/Reports-family/report-folder/sub_report_1
/Organisation/Project/Reports/Reports-family/report-folder/sub_report_1
/Organisation/Project/Reports/Reports-family/report-folder/sub_report_1.jrxml
/Project/Reports/Reports-family/report-folder/sub_report_1.jrxml
/Project/Reports/Reports-family/report-folder/sub_report_1
sub_report_1
sub_report_1.jrxml
./sub_report_1.jrxml
./sub_report_1
repo:sub_report_1
repo:sub_report_1.jrxml

If someone have any clue to how I can solve this issue, he would have all my thanks.

erwanletutour.elt's picture
Joined: Feb 11 2022 - 1:00am
Last seen: 1 month 1 week ago

1 Answer:

In my case, I have the subreports in a folder called subreports, so follow the next path

"repo:/subreports/report.jrxml"

I have placed the address parameter as:

<parameter name="DIR_SERVER_SUBREPORTS" class="java.lang.String" isForPrompting="false">
        <defaultValueExpression><![CDATA["repo:/subreports/"]]></defaultValueExpression>
 </parameter>

So in the subreport I only have to place the parameter + the report

$P{DIR_SERVER_SUBREPORTS} + "subreport.jrxml"

Note: Do not use - to separate words, as this is not recognized by jasperserver, use _ instead.

erikmarbad's picture
Joined: Feb 2 2022 - 5:31pm
Last seen: 2 hours 19 min ago
Feedback