Trouble running reports with rest_v2

Hello everyone, I´m having troubles running my reports with rest_v2, when I run my report with this link for example   http://server:port/jasperserver/rest_v2/reports/interactive/CustomersReport I´m getting a message saying Page not found, and when I run server:port/jasperserver/rest_v2/resources I´m getting the information correctly, and I'm using the jasperadmin user, so if you can help me if I have to configure something I will appreciate it.

sotzedwin's picture
Joined: Apr 20 2022 - 6:20pm
Last seen: 6 months 1 week ago

hi

you can see the correct path of the report by right clicking on the report in jasper server and selecting menu properties

erika.chinchio - 1 year 2 weeks ago

3 Answers:

The reports service call format is:

http://<host>:<port>/jasperserver[-pro]/rest_v2/reports/path/to/report.<format>?<arguments>

Best thing to do is to log in to the JR Server as 'jasperadmin' and determine the exact path by looking at the properties of the report which can then the path to use for the REST call. 

 

vchiem's picture
36613
Joined: May 1 2017 - 5:33pm
Last seen: 1 week 2 days ago

Thansk for the answer vchiem, I tried already typing the format at the end of the path, it doesn't have arguments, and when I press enter the path disappear and do nothing. I don't know what to do.

sotzedwin's picture
Joined: Apr 20 2022 - 6:20pm
Last seen: 6 months 1 week ago

hi

you can see the correct path of the report by right clicking on the report in jasper server and selecting menu properties

erika.chinchio's picture
Joined: Feb 25 2021 - 2:06am
Last seen: 3 days 4 hours ago
Feedback