Getting error when trying to deploy Jasper on docker

I am attempting to deploy TIBCO JasperReports Server on Docker using the information about setting up Jaspersoft in Docker at for version 8.0

As per instructions I downloaded the Enterprise Edition War File and put the in the js-docker directory and then ran the

When I run docker-compose build I get the following error /usr/local/scripts/ not found and the
Service 'jasperserver-buildomatic' fails to build

Attached is the result of the docker-compose build


Attachments:'s picture
Joined: Jul 7 2021 - 10:57am
Last seen: 9 months 5 days ago

that script is located in the docker material you downloaded form the github.  Since the first part of the path is usr/local/scripts I believe it may be your working directory.   You need to run the build command and other commands from specific directories.   <CONTAINER_PATH>/jaspersoft-containers/Docker/jrs    the build command is from this directory after setting up your .env and file correctly.     the unpack command is run from the scripts directory...Run cd <CONTAINER_PATH>/jaspersoft-containers/Docker/jrs/scripts and then run ./      If your path is not resolving correctly per these steps you could symlink to the directory containing this script in the github material and folder structure and then run the build so that it finds the script correctly although I also used this material recently without issue.  Thanks.

rmeadows - 1 year 7 months ago

I think you must be running docker desktop on windows.

Had this issue too, and solved it editing the files in scripts directory with notepad++ and transforming end of lines to unix stye.

asienot - 1 year 1 month ago

0 Answers:

No answers yet