Error running report on JasperReports Server

In jasper studio the report works, but when passing to jasperreports it returns this error. I created two parameters, a start and an end date for the search. I have to treat the dates to the yyyy-mm-dd format before inserting them in the select command, because the typed date is in the dd-mm-yyyy format. I think this might not be working on JasperReports Server.

ERROR SecureExceptionHandlerImpl,http-nio-8080-exec-1:116 - Ocorreu um erro no servidor. Tente novamente ou entre em contato com os administradores do site. (UID do erro: 9a2c1296-d04c-4fd9-91bc-844232c6be85)
2022-01-25T11:09:00,602 ERROR ErrorPageHandlerAction,http-nio-8080-exec-1:118 - Error UID 9a2c1296-d04c-4fd9-91bc-844232c6be85 com.jaspersoft.jasperserver.api.JSException: Error filling report
Arguments:
at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.EngineServiceImpl$FillResultListener.reportFillError(EngineServiceImpl.java:1339)
at net.sf.jasperreports.engine.fill.BaseFillHandle.notifyError(BaseFillHandle.java:228)
at net.sf.jasperreports.engine.fill.BaseFillHandle$ReportFill.run(BaseFillHandle.java:150)
at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.EngineServiceImpl$SynchronousExecutor.execute(EngineServiceImpl.java:959)
at net.sf.jasperreports.engine.fill.BaseFillHandle.startFill(BaseFillHandle.java:181)
at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.EngineServiceImpl$AsynchronousReportFiller.fillReport(EngineServiceImpl.java:910)
at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.EngineServiceImpl.fillReport(EngineServiceImpl.java:1857)
at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.EngineServiceImpl$ReportFill.runWithDataSource(EngineServiceImpl.java:1162)
at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.EngineServiceImpl$ReportFill.runReport(EngineServiceImpl.java:1103)
at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.EngineServiceImpl$ReportRunnable.run(EngineServiceImpl.java:981)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)
Caused by: net.sf.jasperreports.engine.JRException: Byte data not found at: repo:logoFuned.png.
at net.sf.jasperreports.repo.RepositoryUtil.getBytesFromLocation(RepositoryUtil.java:215)
at net.sf.jasperreports.renderers.util.RendererUtil.getNonLazyRenderable(RendererUtil.java:179)
at net.sf.jasperreports.engine.fill.JRFillImage.evaluateImage(JRFillImage.java:526)
at net.sf.jasperreports.engine.fill.JRFillImage.evaluate(JRFillImage.java:451)
at net.sf.jasperreports.engine.fill.JRFillElementContainer.evaluate(JRFillElementContainer.java:383)
at net.sf.jasperreports.engine.fill.JRFillBand.evaluate(JRFillBand.java:548)
at net.sf.jasperreports.engine.fill.JRVerticalFiller.fillTitle(JRVerticalFiller.java:325)
at net.sf.jasperreports.engine.fill.JRVerticalFiller.fillReportStart(JRVerticalFiller.java:258)
at net.sf.jasperreports.engine.fill.JRVerticalFiller.fillReport(JRVerticalFiller.java:110)
at net.sf.jasperreports.engine.fill.JRBaseFiller.fill(JRBaseFiller.java:621)
at net.sf.jasperreports.engine.fill.BaseFillHandle$ReportFill.run(BaseFillHandle.java:135)
... 10 more

etore.marques's picture
Joined: Apr 25 2018 - 5:46am
Last seen: 3 months 2 weeks ago

Hi Etore.Marques, 

The log says about a missing png file -

"Caused by: net.sf.jasperreports.engine.JRException: Byte data not found at: repo:logoFuned.png."

can you try editing the published report on the server and check the path of the resource logoFuned.png. and point to the right place? 

jojacob - 3 months 2 weeks ago

Thanks. I really hadn't seen that this is the image file that was missing from the JasperReports Server.

etore.marques - 3 months 2 weeks ago

0 Answers:

No answers yet
Feedback
randomness