Error: Invalid column type: 2000

0

Hi everyone,

I got this error when I try to implement a store procedure with TIBCO Jaspersoft® Studio Professional 7.3.0 - Visual Designer for JasperReports 6.8.1. I changed the language for PLSQL and I tried to put the fields manually but it doesn't work for me, and I tested with only one field and still doesn´t work ¿Does anyone know how can I resolve this error using this Jasper version? I appreciate your answers.

Caused by: java.sql.SQLException: Invalid column type: 2000
    at oracle.jdbc.driver.OracleStatement.getInternalType(OracleStatement.java:4031)
    at oracle.jdbc.driver.OraclePreparedStatement.setNullCritical(OraclePreparedStatement.java:4182)
    at oracle.jdbc.driver.OraclePreparedStatement.setNull(OraclePreparedStatement.java:4166)
    at oracle.jdbc.driver.OraclePreparedStatementWrapper.setNull(OraclePreparedStatementWrapper.java:1008)
    at net.sf.jasperreports.engine.query.JRJdbcQueryExecuter.setStatementParameter(JRJdbcQueryExecuter.java:788)
    at net.sf.jasperreports.engine.query.JRJdbcQueryExecuter.setStatementParameter(JRJdbcQueryExecuter.java:589)
    at net.sf.jasperreports.engine.query.JRJdbcQueryExecuter$1.visit(JRJdbcQueryExecuter.java:497)
    at net.sf.jasperreports.engine.query.JRAbstractQueryExecuter$QueryParameter.accept(JRAbstractQueryExecuter.java:164)
    at net.sf.jasperreports.engine.query.JRAbstractQueryExecuter.visitQueryParameters(JRAbstractQueryExecuter.java:686)
    at net.sf.jasperreports.engine.query.JRJdbcQueryExecuter.createStatement(JRJdbcQueryExecuter.java:482)
    ... 7 more

 

 

ginna.salamanca's picture
Joined: Nov 17 2021 - 2:31pm
Last seen: 2 weeks 2 days ago

0 Answers:

No answers yet
Feedback
randomness