Jaspersoft Studio issues

0

Hi guys!

I recently updated my Studio 7.5 prof to the 7.9 using the workaround for Big Sur posted here. Additionally, I downloaded and installed the 6.17 CE version, which I'd prefer to use over the prof.

With both versions, it happens the same issues, which causes Studio to be almost unusable. Thing is, I can't find any help about how to solve these issues. So I'd appreciate if anyone can help here.

Here is the list of issues I'm facing:

  • Once I close the Studio window and reopen it. It never saves the configuration. Always starts maximized and showing a lot of issues on the logs.
  • Until 7.5 I was using the repo:style_file_template to reference my style template on reports. The file's always in the same folder as the report. But, this isn't working on these new versions. I need to modify it using the full path of the file on the server. 
  • I'm not able to change the JRE on any project, I always get an error message.
  • I was using a scriptlet in all my reports. Now when I try to execute the report I got an error saying the scriptlet isn't there. But I've added the scriplet to the project as I did it before.
  • [UPDATE] didn't mention I tried with existing workspaces and deleting everything and starting from scratch

Here an image of some of the errors I got.

Error trying to change JRE:

 

 

 

 

 

 

 

 

 

 

 

 

 

Thanks in advance!

 

Regards

Anibal D 

Attachments: 
anibal.duardo's picture
Joined: Mar 27 2013 - 9:21am
Last seen: 6 hours 17 min ago

1 Answer:

0

I use custom java function in my project and also getting this error after update from 6.16 to 6.17 (Clean install of 6.17 also got the same error)

Project was open with 6.16 just fine source code of function also in the same project with jrxml

Start Report Execution
Compiling report......net.sf.jasperreports.engine.JRException: Errors were encountered when compiling report expressions class file:
1. Only a type can be imported. mypackage.mycustomFunctions.myCustomFunctions.FUNCTION1 resolves to a package
import static mypackage.mycustomFunctions.myCustomFunctions.FUNCTION1;
              <------------------------------------------------------->
2. Only a type can be imported. mypackage.mycustomFunctions.myCustomFunctions.FUNCTION2 resolves to a package
import static mypackage.mycustomFunctions.myCustomFunctions.FUNCTION2;
              <------------------------------------------------------->
[Error message was repeat for all of myu function]
then error on all of function called to my custom function
9. The method FUNCTION1() is undefined for the type MYREPORT
                value = FUNCTION1()

I have to clean install 6.16 in order to make it work again.

polppol's picture
Joined: Dec 15 2017 - 10:21pm
Last seen: 3 days 9 hours ago
Feedback