Can only interact with SQL data once

0

I am encountering a strange error in Jasper Studio community edition on Windows 10.

I was able to connect to a Microsoft SQL server and create a new Data Adapter, but after testing it once, the 2nd test fails with this error.

com.microsoft.sqlserver.jdbc.SQLServerException: This driver is not configured for integrated authentication. ClientConnectionId:b489309e-eff4-46e9-9ecc-4dd5b053e8bb

I have to restart the program to get it to actually work again, because I constantly get the same error until I do.

I am able to save it and when I try to create a data source, I can see the structure and tables of the server, but any time I try and interact with the server, even just selecting from a table, I get the same error.

I tried searching for solutions but couln't find anything.

Thank you

roaddogg2k2's picture
Joined: Nov 15 2019 - 11:01am
Last seen: 1 month 4 days ago

1 Answer:

0

Hi roaddogg2k2

Try a different jdbc driver like org.hsqldb.jdbcDriver driver instead of com.microsoft.sqlserver.jdbc.SQLServerDriver
Maybe this will fix your problem?

Greets, A3an

A3an's picture
65
Joined: Apr 10 2016 - 3:13am
Last seen: 4 days 17 hours ago
Feedback
randomness