How to connect to remote server postgre?

0

hello all, so lets go to the main point.

i already did ALL documentations provided but nothing!
heres what i did :
1. install jasper
2. have postgre 9.5 in app server
3. have same postgre 9.5 in db server
4. test wether they can connect (yes they can connect)
5. change buildomatic/default_master.properties parameter, META_INF/context.xml
6. clean config
7. gen config
8. js-install.sh minimal
9. DB created
10. start service with "ctlscript.sh start"
11. postgre connect to 5432 (in remote server its 5551)

how to setup the connection to the right port?

any idea?
pls help, any idea might give me a clue.

regards, -TV

trvpseudo's picture
Joined: Jan 30 2019 - 11:02pm
Last seen: 2 weeks 1 day ago

fyi, the 5432 in console is a hardcode string, can ignore it or change it somewhere in postgre folder. find the script used to turn on postgre and u'll find the hardcode text.
regardless, if u do the step above it shouldve been connect to the assigned DB.

trvpseudo - 1 month 2 weeks ago

3 Answers:

0

found the way for bundling version

- if you need to create DB first in remote server follow this step:
1. install the jasperserver with .run (linux)
2. change in buildomatic default_master.properties : host, port, dbusername, password & ucomment something like "js.dbName = jasperserver" (can change jasperserver to ur custom DB name else it will create DB by the default name jasperserver)
3. change jasperserver file META-INF/context.xml, change username, password & url
4. go to buildomatic command prompt and do './js-ant clean-config' then './js-ant gen-config' (using linux, if windows without ./ )
5. then do './js-install.sh minimal' (minimal = no sample data), this step will create the DB with the new config in default_master.properties

note that u need existing credential within the server allowed to create DB so buildomatic can create the DB.

- if you already have DB created within the remote server :
1. simply change username, password and url in webapps/jasperserver/meta-inf/context.xml
2. restart jasperserver

it shouldve connect to remote server.

Regards, - TV - last update 13 aug 2020

trvpseudo's picture
Joined: Jan 30 2019 - 11:02pm
Last seen: 2 weeks 1 day ago
1

Don't really know the install process but I remember you can try the install with a --test option. Did you try it ?

And the error says 'denied', did you check the users and permissions used in your properties/xml files ?

Hope you'll find the answer soon.

Yann

Yann22300's picture
Joined: Apr 29 2015 - 1:10am
Last seen: 1 day 25 min ago
0

thank you
and i did already tried it. so its because the admin dont allow my userid to crate omg..

now the DB has been created in remote server, cant connect to it when i start the ctlscript.sh start
the postgre seems to connect to port default 5432 not the port i specified like 5551

any idea about that?
thanks a lot

trvpseudo's picture
Joined: Jan 30 2019 - 11:02pm
Last seen: 2 weeks 1 day ago
Feedback