Jaspersoft Studio Table Row Height Not Stretching

0

I am working on a Jaspersoft Report that contains a table in the 'Summary' band. This table contains two rows and the bottom row occasionally will contain too much text for the default height setting of the row. Currently, the row does not stretch or expand when the text is too long. Instead, it simply truncates the text. My goal is for the row to stretch/expand height to fit the text.

I searched on the Jaspersoft documentation and forums and found numerous people with similar issues. However, none of the proposed solutions actually worked. I tried changing the 'Stretch Type' of the text fields to 'Relative to Tallest Object' and that did not work. I tried selecting 'vertical ordering' for the table cells and that did not work.

I'm not sure where to go from here and any help would be greatly appreciated. I have attached a screenshot showing an example row where the text is being truncated. The selection in the red rectangle contains more text and I would like for that text to be fully displayed instead of being cut off.

Thank you!

Dustin Walker

dustin.walker's picture
Joined: Aug 15 2016 - 11:57am
Last seen: 1 week 4 days ago
luked - 2 weeks 2 days ago

I am wondering if the Windows and Mac OS X versions of Jaspersoft Studio are different. I am currently on version 6.11.0 for Mac OS X and my properties window does not show 'Stretch with Overflow'. I have attached a screenshot of the properies tab for a text field from my version.

I was able to get this working my manually adding the property to the XML file but I could not get it to work using the Jaspersoft Studio GUI. I am curious if anybody else has run into this problem.

dustin.walker - 2 weeks 1 day ago

1 Answer:

0

Hello!

Did you try to change properties of band? It has the property 'Split type'.

avkuzmenko75_1's picture
Joined: Jan 20 2020 - 8:57am
Last seen: 1 day 17 hours ago
Feedback