Insufficient memory for Java Runtime Enviroment to continue

0

Hello, again and still I have the problem that my jasperserver on a Vultr VM breaks after generating around 400 reports.

I want to limit the java heap size but how to do this on a Ubuntu server?

nick_39's picture
Joined: Jun 4 2019 - 10:15pm
Last seen: 3 weeks 4 days ago

In the setenv.sh I added 2 lines and I hope they work:

JAVA_OPTS="-Xms1024m -Xmx2048m -Xss2m $JAVA_OPTS " # java-memory-settings
export CATALINA_OPTS="-Xms1024M -Xmx2048m"

nick_39 - 3 weeks 5 days ago

1 Answer:

0

Hello,

That looks like the correct configuration, but if you are still having issues with 2G of heap space, I would suggest adding more. MOre information on JVM options can be found here:

https://community.jaspersoft.com/documentation/tibco-jasperreports-server-community-project-source-build-guide/v720/java-options-and

Thanks,

Paul Jimenez
Support Engineer
Tibco Jaspersoft

pjimenez_2's picture
2217
Joined: Oct 26 2016 - 11:39am
Last seen: 1 week 2 days ago
Feedback
randomness