Oracle JDBC connection not working

0

Dear all, 

After uccessfull installation of Jasper Server ( 7.1.1. ) on Windows 2016 and installing jdbc drivers for Oracle (ojdbc6 or ojdbc8 ) I tried to create Data source. 

When testing the connection, system returns an error : 

'There was an error on the server. Try again or contact site administrators. (Error UID: 17451563-792e-42e2-b4c5-6db755ccd5e7)"

Oracle database is 11G XE

The same thing with the 7.2 version. 

Any ideas ? 

Thank you and Best Regards, 

Zoran Kuret

 

zoran.kuret's picture
Joined: Apr 23 2017 - 3:33am
Last seen: 4 days 22 hours ago

2 Answers:

0

contact me eduardojoseramos@hotmail.com. I saw your post in upwork.

eduardojoseramos's picture
Joined: Oct 18 2017 - 5:41pm
Last seen: 3 hours 11 min ago
0

Hi

I have the same problem.

I have tried with drivers 6,7 y 8 JDBC.jar, but my database is 18XE.  
My tomcat is 9 and JasperServer 7. 

JRE and JDK:8

Checking the catalina log I have  found more details, because the jasper log just said that ERROR UID.

06-Nov-2019 16:34:25.651 ADVERTENCIA [http-nio-8080-exec-2] oracle.jdbc.driver.OracleDriver.registerMBeans Error while registering Oracle JDBC Diagnosability MBean.
    java.lang.ExceptionInInitializerError

     ......

     ......

Caused by: java.lang.IllegalArgumentException: name
        at sun.misc.URLClassPath$Loader.findResource(URLClassPath.java:703)
        at sun.misc.URLClassPath.findResource(URLClassPath.java:225)
        at java.net.URLClassLoader$2.run(URLClassLoader.java:572)
        at java.net.URLClassLoader$2.run(URLClassLoader.java:570)

 

Thanks

 

 

 

dburela's picture
Joined: Aug 7 2019 - 6:14am
Last seen: 9 min 34 sec ago
Feedback
randomness