subreports not visible in the main report

0

I have sub reports that I include in a main report. My problem is that my subreports are not visible when I previsualize the main report. I gave a source to the main report and the data came out without problem. there are only the subreports of the main report that do not go out.how to manage this situation?

tiamtienkam's picture
Joined: Aug 20 2019 - 2:50am
Last seen: 2 weeks 2 days ago

1 Answer:

0

Hello,

Can you please clarify a bit.

"My problem is that my subreports are not visible when I previsualize the main report. "

What elements are you using?  (ie: Text field, table, chart)

What do you mean the subreport is not visible when previsualize?  Do ou mean you do not see the fields in the list of the element or that the element does not render when previewing the report?

Sub-reports fields are not available in Text elements.  Those are reserved for main report fields.

I can assume you mean when previewing.  Do you have the print when properties set or transparent set?

 

 

I have had display problems that were resolved by the following steps:

1. Delete the page element

2. Create a variable called anything with the expression as ""      (just the two quotes. simulating blank)

3. create a group based on the variable

4. Add the page element back in the group band.

5. Set the report property When No Data Type to "All Sections No Detail

danoldenkamp@gmail.com's picture
Joined: Aug 29 2018 - 11:12am
Last seen: 9 hours 36 min ago
Feedback